iBook boot problems (bad logic board???)


Hello, I hope someone on here can help me with a problem I'm having.

I recently purchased an iBook g3 logic board off eBay with the intention of using it as the core of my carputer project and I can't get it to boot.

First off lemme give you the details of what I have and what I've done.

What I have is a standard iBook g3 500Mhz logic board with the DC board, an external Firewire drive with OS X 10.3 installed, an ac adapter, a Mac USB KB and mouse (white), and a VGA converter plugged into a monitor.

With everything plugged in and connected, I can get the system to power up (using reset button in power button slot) and go into the boot disk selection (holding down option during boot). When it gets to the selection screen it sees my firewire drive and recognizes the OS X installation. I select it and click continue but all that happens is the screen flickers, the HD icon disapperas for a sec, then the system goes back to the boot device discovery phase. The same thing happens when I try to boot from my iPod (also 10.3 installed) and another iBook G3 500 in target mode.

I have tried resetting the PRAM and have reloaded the defaults into the Open Firmware. No luck. The only thing I haven't tried (only because I don't have the HD cable) is booting off the internal IDE connection. I have even gone as far as trying to boot a CD using a standard IDE cdrom and a 2.5" IDE adapter (external power source on CDrom drive). This did nothing more than lock up the system before it reached the boot selection screen. Holding down C didn't help either.

Is there something I'm missing or am I looking at a bad logic board?

Please help!!


BTW, I should mention that the iPod and external FW drive both work and will boot other iBooks (like my wife's G3 700 and a different G3 500).