Ibook G4 Crash



Thank you for a great site!

My 15months old iBook G4 (Panther 1.3.9) crashed yesterday. It simply froze when I used it. If I switched it off to restart it worked for a few minutes before it froze again. (When frozen I could still move the mousepointer. I rang Apple but since my warranty is out I got no help.

Trying on my own I ran single user mode /sbin/fsck -yf and the computer responded several times with reparing volumes and HTF.

When the harddrive seemed OK according to the run above I rebooted but the problem still occured.

I decided to erase the hardrive and reinstall OSX. This is where I am stuck now. When running the Install disc 1/3 it says that an error occured before completion of the installation. When I try to repair from the disc utility mode it says that Mac HD can´t be repaired! And I have no way of ejecting the disc!
If I try to restart without using the install disc the computer stops at the MacOSX window and just stays there.

Please help a newbie, I have erasewd the harddrive and have nothing to lose of data so all methods are worth trying.

Kindest regards,

/Kalle in Sweden


It could be a bad RAM stick. I've had that problem on my Linux box when it suddenly started crashing, for no apparent reason. Tried everything and finally decided to reinstall the OS. Hung at halfway through the installation because of some error. After much hair pulling and head banging, found out that it was the memory. Swapped it and it now works fine.

If you want to eject the disc, when the computer is starting up, hold down the mouse button. That causes the disc in the drive to be ejected.

For solving your problem, you might want to try removing any memory that you had installed yourself. See if that solves the problem. Only bad thing is, if it happens to be the built-in RAM that has gone bad ... we'll cross that bridge if it comes :)