Ibook Is Slow Booting


Okay, quick run down, i have a 2 week old g4 ibook, 1.33ghz, 40gb , 512mb. I have a problem with the start up time, it takes a long time, at first you see an apple in the middle, it takes about a minute and a half, then a small gear starts turning then it takes a further 2 minutes to load.
I read your answers to other peoples questions regarding similar problems. So i firstly ran hardware check and that came back all ok (it runs fine once you get past the boot up).
Secondly i ran disk utility from the osx start-up cd. I checked the disk which it said was ok. Then i checked file permissions and it came back with these problems:
"using special permissions for the file or directory ./Library/Widgets. New permissions are 16877
Permissions differ on ./Library/Widgets, should be drwxr-xr-x, they are drwxrxr-x

using special permissions for file or directory ./usr/lib/php/build/acinclude.m4 New permissions are 33060"

I then ran repair, and it supposedly repaired the problem. I ran repair again as i had read in your answers to other queries just to check, and it came back all ok. I rebooted the computer and she started perfectly, now this is where the problem arises!

I shut down my computer thinking the problem was solved, but when i went to start up the computer this morning it was as slow as ever again. So i ran disk utility again, and sure enough the same message appeared as outlined above. What the??? I thought these permissions were fixed but somehow the computer has screwed up the permissions again. How do i perminantly fix these permissions so the start-up will return to normal???? Thank you in advance! J

Have you upgraded from 10.4.0 to 10.4.2 yet? If so, you should call apple. You get 1 month of tech support during the first year, so I think it's time you start that month now. They hopefully have a fix for this. You could also call a local Applestore and make an Genius bar appointment to bring it in. They should also be able to do something about this.