Ibook Restarted Into Hell!

Aeviterna

Registered
My iBook always worked fine. I'm running Panther. This morning, I restarted it, and I got the usual "MAC OSX" screen with the blue background and status bar.

It would always say things like "waiting for network initialization" above the status bar, but this time, it just went black and brought me into the Darwin console.

When in Darwin, it promped for login information and password, which I provided, and they were correct, and I know that my home folder is still intact.

My question is, why did this happen, how do I get out of it, and what can I do to prevent this from happening again?

Thank you very much for your time.
 

TommyWillB

Registered
Did you have the Command + S keys pressed when you started up?

That would boot the machine in single user mode...
 

Aeviterna

Registered
I've tried starting it up in Single User Mode, Verbose Mode, "Safe Boot," Open Firmware Mode, Bypassing the Internal Hard Drive, I've reset the PRAM and NVRAM, I've tried using the startup manager (only one volume to select with "X" logo, the correct volume, I'm assuming), and nothing seems to work. I also ran fsck and it said the Hard Disk was just fine.
 

designsforme

Registered
I have the same problem, but I'm running Tiger. I restarted and the same deal happened. It flashed the login screen and then dumped into Darwin and asked to login. So I restarted and held command + S and got into the shell manually and then I ran this program called "Apple Jack" and it found an error in the catalog is there any way to get this fixed or does it mean I have to do a format and reinstall.

Thanks
 
Top