Ibookg3 Dvd-r Problem


i recently tried to insert a DVD-R, which had been burned on another Mac, into my iBookG3 with a ComboDrive, but the disc was spit out immediately. This occured with another DVD-R, too. A third DVD-R just kept spinning, but I couldn't mount it. This has not happened before, and it doesn't happen either with a movie DVD which I have bought (I guess this is a DVD-ROM).
I have recently updated to OS 10.3.9, could this be the reason?
I have also tried to find some help on apple's support-website, but couldn't find any helpful document.
The system profiler says the following about my combodrive:

Manufacturer: TOSHIBA
Revision: 1P19
Serial Number: 62KI804154
Drive Type: CD-RW/DVD-ROM
Disc Burning: Apple Supported/Shipped
Removable Media: Yes
Detachable Drive: No
Protocol: ATAPI
Unit Number: 1
Socket Type: Internal

I would greatly appreciate any help.
Your COMBO drive should be capable of reading any DVD-r discs, so if your drive can read DVD-ROM discs maybe the problem could be the disc.

I recommend you try with another DVD-r, I have seen issues like this related just to the disc, maybe the quality of the disc is not the best and usually some drives can not read some discs, at least I had that experience, even when another computers can read the same disc.

Try with another disc from another manufacturer.