Ical 2.0.1 Publish to Webdav Server



I have upgraded to Tiger and since then have been unable to publish my calendar to my local WebDAV server. This worked fine before the upgrade. After the upgrade, I can still connect to the WebDAV server via the Finder (Go->Connect to server->etc.). However, iCal gives me an authentication error--even when I'm connected to the same server via the Finder using the same authentication. I have deleted all my keychains with regard to this server and re-typed passwords and usernames at least 50 times...still get the authentication errors in iCal.

Is iCal looking for a different kind of authentication than the Finder? Is there a way around this problem that you've heard about?

We've just had a discussion in a danish news group regarding this very same problem. It seems as if iCal !dosn't! send the authentication even though it says so. See these log extracts:

213.237.x.x - s022518 [27/Oct/2005:10:48:23 +0200] "PROPFIND /02120/webdav/ HTTP/1.1" 207 559
213.237.x.x - s022518 [27/Oct/2005:10:48:23 +0200] "LOCK /02120/webdav/kalendere/apache_pb.gif HTTP/1.1" 200 467
213.237.x.x - s022518 [27/Oct/2005:10:48:23 +0200] "GET /02120/webdav/kalendere/apache_pb.gif HTTP/1.1" 304 -
213.237.x.x - s022518 [27/Oct/2005:10:48:23 +0200] "PUT /02120/webdav/kalendere/apache_pb.gif HTTP/1.1" 204 -
213.237.x.x - s022518 [27/Oct/2005:10:48:23 +0200] "PROPFIND /02120/webdav/kalendere/apache_pb.gif HTTP/1.1" 207 449
213.237.x.x - s022518 [27/Oct/2005:10:48:23 +0200] "UNLOCK /02120/webdav/kalendere/apache_pb.gif HTTP/1.1" 204 -

213.237.x.x - - [27/Oct/2005:10:49:45 +0200] "PROPFIND /0120/webdav/kalendere HTTP/1.1" 405 315
213.237.x.x - - [27/Oct/2005:10:49:45 +0200] "DELETE /0120/webdav/kalendere/Hjem.ics HTTP/1.1" 405 322
213.237.x.x - - [27/Oct/2005:10:49:46 +0200] "PUT /0120/webdav/kalendere/Hjem.ics HTTP/1.1" 405 319

The first block is from an upload of a file using Finder - no problems
The second is an attempt of uploading a calendar through iCal.
Note, that in the second block the username - s022518 - is missing from the log lines.

The server is Apache 2.0.55 with all the bells and whistles on a Linux box.
MacOS X 10.4.2 Client / iCal 2.0.2 (1038)