iChat suddenly wants a new install, yet hangs at "done"


Hello, all -
I'm new to the Forum, and hope someone might be able to help me. I'm stumped. I'm having a problem with iChat. It was working fine yesterday, and this morning, when I launched it, it went into "install" mode. I thought that was odd, but followed along and although it hung for a while at the "jabber" and "bonjour" windows, it finally made it to the "conclusion" window. When I click "done," however, I just get a never-ending hang, and either have to force quit to get out, or iChat just suddenly quits on its own.

I've tried a few things, such as repairing permissions, etc. With no luck.

I'm on a G4, running OS 10.4.2

I'm not sure what could've provoked this, and can't seem to fix it.

Any thoughts?


I have no assistance for you other than to say that I'm having the EXACT same problem. I've been on the phone with Apple support several times on the issue, and their only answer is, "Archive and Re-install". Big help that is. I've also searched several fora in order to find out that there are others experiencing the same issue, but no one seems to have any answers at this point.

If you find anything out, PLEASE let me know. I'd really like to get it working again, but don't want to go through the hassle of losing all of my system hacks/add-ins and having to set them up again after a re-install if I don't have to.

Maybe we can compare notes on some system specs, add-ins, etc. to see if there are some commonalities in our setup. The only thing I found out new tonight is that the info screen on iChat on my system shows 3.0, not 3.0.1 right now. Not sure if this means it didn't get updated correctly when I updated to 10.4.2, or if it is just not reporting correctly.


The Late: SuperMacMod
Try trashing these preference files;


Located here;


Trash the iChat Cache folder located here;


Then try iChat. You'll have to set it up again.

If this doesn't work, do all of the above again, and also trash the iChat application.

Reapir Permissions again

Boot off the Tiger disc and use Disk Utility under the Utility Menu (after selecting Language) to Repair Disc.

Then do a Custom install from the disc, only installing iChat.


I found the answer - at least it worked for me. I checked the info pane for iChat and it was showing 3.0. I thought this was odd since 10.4.2 was supposed to update it to 3.0.1. I re-downloaded the stand alone installer for the update and re-ran it. After re-patching my system and restarting, I checked the version on iChat, and it was reading correctly at 3.0.1. I started it, and it came right on - no setup screens - right back to my last configuration with all of my entries right where I left them. Weird.