IE doesn't work

ablack6596

Registered
Why do I get this error when I try to open the version of IE that came with Mac OS X.1.
:) Thanks:)
 

Attachments

Top