IE for OS X can't view PNG's

serpicolugnut

OS X Supreme Being
Just discovered this while visiting go2mac.com. They have a .PNG on their site of their new Darwin installation. Anyway - IE 5.1.2 can't view it and doesn't know what to do with it. Very strange. Even OmniWeb can view the file.

I can't believe MS would leave out an image format that is so widely used...
 

scruffy

Notorious Olive Counter
Ah, but PNG is an image format that is widely used by open source enthusiasts, in reaction to restrictive patent rules surrounding GIF.

As a historical note:
Way back when, MS decided that it would make its browser pretend to web servers that it was Netscape - why is that? Because it stopped servers maintaining separate versions of the site for IE and MS, that took into account IE's many bugs. Then IE users just saw a broken site, complained, and forced server admins to make every version of the site take IE bugs into account - ignoring the (at the time) superior capabilities of Netscape. Since nobody got to see the (presumably) better designed NS versions of webpages, the superiority of NS wasn't recognized very widely. Thus is a browser war won...

So, why cripple PNG - because those evil Linux types use it. People are hardly going to move over to Linux if they think, "those stupid Linux people, they can't even make a website that works"

More likely, MS doesn't care enough about OS X to fix all their bugs.
 

Jorace

Registered
I can view png files in IE no prob.

If for some reason you cant, set QT plugin to be the helper for png.
 

Soapvox

Want some of my Kool-aid?
I just built a page and used a png background shows up fine in IE on X. Just a little rant here, all web developers out there remember that there are 3 image formats out there and that compuserve (who owns the copyright to gif) is charging software companies a fee to use gif compression, convert your non animated gifs to png, you get better quality and smaller files and we promote open standards like png and jpeg. Down with the gif, if you need animation use flash, long live PNG!
 

walrusjb

Registered
The problem seems to be between 8 and 24bit PNG files. The smaller image on Go2Mac is actually a PNG itself - likely an 8bit. Perhaps the larger is a 24bit? This is consistent with IE's behavior on PC if this is the case.

Will try it out later + see if this is the case.

-jb
 

PBG4 Dude

Registered
Just looked at the site using IE for windows. No problem viewing the picture. I do know that I had the exact same problem in OS x.0.4, I don't know if I still have it in 10.1. I will check when I get home later.
 

soellman

nice face!
Originally posted by Jorace
If for some reason you cant, set QT plugin to be the helper for png.
huh.. so how do you do this exactly? I've found that IE since the beginning (osx beta) will not recognize non-classic (yes, classic) plugins and helper applications in the dialog where you select them. So for png (which works fine for me as an inline image, but not when opened up by itself), I tried to have it open the qt player or even preview, and it won't let me select those apps.

I just erased all my classic apps during a rebuild last week, so I can't say if this is still what I'm seeing.. but I can't select carbon apps. grr!
 

zerologic

No Wh9ing!
the fix is easy.

Explorer > Preferences > File Helpers

click "Extension" in the upper right corner of the dialog (sorts by extension)

if there is more than one .png delete them until you only have one left. Double-click it.

Change the "How to handle" to "view with browser"

Save it. Close it. Try again.

Michael.
 

soellman

nice face!
Originally posted by zerologic
the fix is easy.

Explorer > Preferences > File Helpers
duh.. thanks! works like a champ.. there were two, one was image/png (set to view with preview.app) and the other image/x-png (set to view with browser). I set the image/png to view with browser and we're all set!

Although I suppose this could further demonstrate that IE can't call carbon/cocoa helper apps.. can't be bothered with more testing though.

thanks!
 
Top