Imac G4 20" Sleep Problem

MacSlafko

Registered
My iMac won't go to sleep although I have set the timing for that (30 min) in Energy saver. It works alright when I manually choose Sleep from Apple menu, but it doesn't work when I leave the computer for an hour or two.
I've noticed some "click" sound every 10-15 minutes, but I don't know how to determinate what it is. Like the HD spin sound?
And yes, I disconnected every peripheral device. Even the applications are quited, but it won't go to sleep.
Any ideas?

Thanks, and greetings from Croatia!
 

lkb

Registered
MacSlafko, I have a 17" G4 iMac that JUST recently started doing this EXACT SAME THING!!!

I have tried everything from PRAM reset to holding the power button until the loud tone (reset). I have trashed the energy saver prefs and I have disconnected everything except the keyboard, and it still wont sleep, and I hear the click sound mentioned above as well.

At this point, I am suspecting that perhaps this issue has been introduced by one of the recent OS patches or something because the only thing that has changed on this system is that I run Software Update weekly and install all updates (Tiger).

So, anyone else have this, or MacSlafko...did you solve yours?
 

mw84

Registered
Same here, not that it's a big issue for me.
 

nixgeek

Mac of the SubGenius! :-)
lkb, where were the preference files that you trashed. Were they in the global Library folder (located in Macintosh HD) or the one in your home folder? Try trashing the ones from both locations and see if that resolves the problem. (Same for the other two posters.)

If that doesn't do it, do the following.

• Reboot you Mac and hold down Apple-S after the start chime. This will put you into Single User Mode.
• At the command prompt, type "/sbin/fsck -yf" and hit Return (note the space in between the command and the switches).
• After it finishes, run it one more time or until it says that the Mac HD is OK.
• Type "reboot" and hit Return to restart the Mac.
• Once at the Finder desktop, go to Applications-->Utilities and launch Disk Utility.
• Select to repair permissions on your hard drive. Run it until it says everything is repaired.
• Reboot and once at the desktop, test the Energy Saver options.

Hopefully this will fix any issues you all are having.

Report back with your results.
 

lkb

Registered
nixgeek...thanks for the reply...I had already ran fsck and DiskWarrior 3.0.3, trashed the preferences in the global dir as well as ones in the user dir as well...nothing seems to work and I can't imagine what the root cause could be other than a software defect that snuck by regression testing or perhaps some chipset specific issue with G4 iMacs.

I have a Pismo 500, a Cube 500, a DP 800 Quicksilver, a 20" iMac G5 1.8, a DP 2.0 G5, and this 17" G4 iMac 1.25 is the only one that has this issue--despite them all having the same OS version and all updates.
 

MacSlafko

Registered
So, anyone else have this, or MacSlafko...did you solve yours?

No, I didn't (so far). I did PRAM reset, i trashed the Prefs on Macintosh DH and in both user's Libraries and I tried to do this NixGeek's tip, but my computer (in command prompt) says that it can't find this "/sbin/fsck -yf" file...

Perhaps 10.4.3 will solve the issue, but somehow I daubt that


Could anybody guess what' the problem?

Thanks!
 

MacSlafko

Registered
Yes, I think you should do it. I've spent some hours (weeks) trying to fix the problem, but non of the solutions offerd on various forums helped. Of course, thanks to all people who shered their experiences on the Internet in order to help, but it just doesn't seem to be enough. So I sugest you to report the bug to Apple, if somebody else didn' already do that (my .Mac account is expired). Afer all, it's their job to fix such bugs.

By the way, last week I spoke with one Apple technican in Croatia and he couldn' think of the reason for this persisting insomnia.

Let me know of any further development, will you?
 

nixgeek

Mac of the SubGenius! :-)
Are you sure that the Energy Saver settings are properly set? How about trying to delete the .plist files for Energy Saver in the Library folder located in both your home folder and in the Macintosh HD? You might have to do a search for them (I'm not in front of my Mac to be able to tell you where they might be exactly).

The other thing you can try is to use the Hardware Diagnostic CD that came with your Mac. Run that and see if it detects any hardware problems that might require Apple's intervention.
 
Top