IMAC G5 OSX10.4 (Wireless 128bit Encryption) and Lynksys WAP54G


Well, opened my new IMAC g5 and hit a roadblock when trying to connect to my Linksys WAP54G access point using 128bit encryption (hex). I was getting connection fine but when trying to browse the net it wouldn't let me. Checked the Client table and sometimes It would show the IMAC and the others it would not.

I'm new to apple and have been a pc guy my whole life so finding sollutions for this seemed more frustrating for the people asking the same question for help than me. Well, I did some trouble shooting and this is what I found that corrected my problem.

Noticed that some individuals were saying that they needed to turn the encryption off in order to browse the net. Well I did this and it worked! Sure this is a great sollution but guess what? I'm open and so is my network so I turned the encryption back on made sure my passwords were correct and boom the same roadblock. NO connection... Checked my pc laptop and it was fine connection was perfect. So why wasn't the IMAC connecting?

Sollution: The Default Transmit Key

Using the Linksys web portal to the WAP54G go into setup and click on "Edit Security Setting" Where it says "Default Transmit Key" make sure this is set to 1. Save the settings and tried reconnecting with the IMAC and it worked!

Some individuals were stating that the problem was either the card or the Linksys product but this wasn't the case (at least for me). I believe it's the OSX and it's ability to recognize Default Transmit keys 2,3,4. Now this is just what worked for me and my equipment but I would recommend trying this with other Linksys wireless networking products before yelling at a CS guy or smashing the IMAC's screen.

I hope this may have helped at least one person out there. If so then this was worth writing :D