iMac internal modem?

Michael_Aos

Registered
Are there any known-issues or "gotcha's" with the Rev-C iMac internal modem and MacOS X?

I tried for quite a while last night to establish an Internet connetion. It just sits there, saying it's "establishing a PPP connection", but it never even tries to dial. Clicking "cancel" gives it a status of "disconnecting" which remains until a reboot.

I've tried "Apple Internal 56K v.90" (default) and "Apple Internal 56K v.34".

It acts like it just doesn't see the modem, or the modem definition is wrong.

HELP! I've used the modem under LinuxPPC in the distant past and it worked fine. This machine is normally connected via ethernet / DSL, so I haven't used the modem regularly.

As an aside, I DON'T have any of the classic environment installed. Just MacOS X. It's been fine in the past, but I'm wondering if the modem is SOMEHOW tied to the classic environment -- it shouldn't be, just grasping at straws here.

Mike
 

sahyun

Registered
My G4 will dial in (to Earthlink) but there is no modem sound; changing the prefs has no effect. In addition, after a few minutes it will randomly drop the connection (usually when downloading a big file.)

Steve
 

Michael_Aos

Registered
I re-installed MacOS X from scratch, and the modem has been working perfectly.

I'm _slowly_ going through the update process to get back to where I was (10.0.3?).

Unfortunately, I'm only connecting at 24K or 26.4K -vs- the 640K DSL I've grown accustomed to.

Bummer.

Mike

P.S. Any tips on bumping / forcing higher connection speeds?
 

davidbrit2

Licensed Computer Geek
The Console.app is a handy program for troubleshooting some things like that. Leave it open and try doing what isn't working, and see what it says. That was the only way I could figure out why Apache wouldn't start from the Sharing preference panel.
 

sgranlund

Registered
I had the same prob, talked to local mac guru who said, "flash your modem"! So, "maybe", do what you have to do to get a copy of the latest "Apple Modem Updater", 2 something, and follow the readme. I was up and dailing as soon as the modem chip was full of new stuff.

-sg

Rev/B 233
40g quantum
256m
4 partitions - 1 is swap! do it!
 

Klink

Member
I to had this problem and found that resetting the modem was all that was needed to be done.

Apple's Knowledge Base Article # 24716

You can reset the modem using AppleWorks or ClarisWorks or another communications application such as Zterm.
1. In AppleWorks, open a new Communications document.
2. Set the Connections Settings as follows:
* Method: Serial Tool
* Baud Rate: 57600
* Parity: None
* Data Bits: 8
* Stop Bits: 1
* Handshake DTR & CTS
* Current Port : Internal (or appropriate port)
3. Select Open Connection from the Session menu (this will let you type modem AT commands)
4. Type the following:
AT&F
Then press the Return key on your keyboard. Wait for the computer to return the OK message.
5. Type the following:
ATZ
Then press the Return key on your keyboard. Wait for the computer to return the OK message. This should reset the modem to the factory default settings.
Alternate Method
Here is an alternate, simpler method of resetting the modem, though it will work only if the software you intend to use relies upon the Modem control panel (for example, ARA 3.0 or OT/PPP):
Open the modem control panel and change the Connect via: to modem/printer port and then change it back to internal modem.
 

sahyun

Registered
Thanks sg,

I found the modem update 2.x off of Apple's support site (software downloads, needed to login though). I ran it after booting into 9.1. Booted back into X and had been on for over an hour and had downloaded a large file, so at first it seemed to work.

However, after initially posting this, I tried connecting via the terminal, and had no end of grief with having the modem disconnect on me. So I guess the update didn't help as much as it first seemed.

I'm on a G4MP w/ internal modem, using the 10.0.4 update. I saw on MacOSX.org that disabling one of the processors was helpful, don't know if I want to try that though.
(I know this doesn't have much connection to the original iMac question, but it seemed like a similar problem at first.)

Steve
 
Top