Install Fix!


Ok i got this from another board but it worked. i always get an error 192 when trying to install programs such as omniweb. So I logging in as root, and it fixed the install problem. I installed my programs with no problems! Give it a try and see if it fixes your install problems.

--from MacFixIt Forums--Logging in as root--

If you want to do this through the Terminal (i.e. when compiling a text-based app like Apache or Tinyfugue -- text based mud client ) you type:

su root
(root password)

You'll then be the root user while operating in that terminal window. To get out of root mode, type 'exit' and you will be reverted to your normal account. I think this doesn't work until you follow the 'enable root' steps below:

To enable the root user in the GUI, you need to start the NetInfo Manager . Click on the / in the left-most pane, then from the Security sub-menu of the Domain menu, enable the root user. (I recall having to type my Administrator password to do this. If you don't have a root password yet, you'll get the chance to set one.)

Now, go to the Apple menu and choose Log Out. You'll have to close all apps to do this. After a few moments, you'll be presented with a log in window along with Shut Down and Restart buttons (unless you disabled these. I didn't.) It's a lot like a Unix X Windows screen.

Type 'root' in the user window and the root password you set earlier in, and you will be logged in as superuser.

DO NOT do this under normal circumstances -- being root is BAD because you can do ANYTHING to the system, even rm -rf / ...

Logging in as root and back does NOT fix the 192 error. Until I find out what is going on, I'll have to log in as root to mount disk images -- hence I'm hoping that the disk permissions I gave above are helpful in finding a fix for the problem.

Powerbook G3 1999 Bronze ("Lombard") w/ MacOS 9.1/OS X, many many extensions!

---End of MacFixIt post--

So try it out and see if it works for you. Just remember to log back out of root when your done. to do that follow the steps above except choose disable root user instead of enable.

Hope it helps you all!
I had a problem with placing new apps into the main application folder. I was told I did not have the proper access. But today I learned that Kensington's Mouseworks (beta2) created this problem. The new release (beta3) appears to have fixed the problem. You still have to do a manual uninstall before installing the new beta, but the problem has gone away.

Go to version tracker to get it.