Installation Failure, iMac DV SE 400

BrandonP

Registered
Okay,
Here's the scoop. I'll warn you now, this is really long. But I don't want to leave anything out.
I have an iMac DV 400 mHz SE slot-loading machine with factory RAM (128) and harddrive.
I bought the OS X CD, and I read everything I could on installing it. That includes the ARS Technica resources and articles, Macintouch articles and Apple's TIL file #43086.
I read about problems uninstalling, so I made a backup with Retrospect after running NUM and making sure I had no disk problems. So far so good.
I booted into OS X on the CD and proceeded to run the installer. It booted really slow and the choices you make in the installer, well, there was a lag between me clicking the mouse and the installer recognizing the click. But it did start installing.
Approximately thirty minutes later the installer said the installation was complete. From what I'v read the machine is supposed to restart automatically, but it didn't. It sat there for ten minutes. I noticed the cursor that previously had been responding had moved from the installer window to the upper left hand corner. It had changed from a black arrow to a spinning multi-color CD. I no longer got a response from mouse or keyboard.
So, I shut down the machine by depressing the front power button. Waited thirty seconds and started up. The machine did it's diagnostic it always does on startup and went into OS 9 like normal. I looked on the harddrive and it had tons of unix-like files at root level and the Mac OS 9 folder was there where it was supposed to be. The system disk icon gave me an error when I double clicked it. I had believed this was the "toggle" panel to choose OS's when running either one. I remembered reading that the machine could launch a bootloader (I think that's the term) upon startup if the option key is depressed.
So I restarted and held down the option key. It searched and displayed three icons: the search icon (swirly arrow), the Mac OS 9 icon, and the proceed icon (straight arrow). I proceeded with startup into OS 9 again.
I guessed that maybe the installation hadn't finished like the installer said, so I rebooted into the OS X CD. BTW-TIL article #106025 sounds like it's going to address this, but it doesn't. I reran the installer. Things proceeded quickly this time (approximately fifteen minutes beginning to end). This time the installer locked up again just like the first time. Identical behavior once it said installation was complete. I let it sit for over thirty minutes in case there was a background function running. It never responded, same spinning CD and everything.
I shut down just like I did before.
This time when I started up, the OS 9 loaded, but Serial Port Monitor from Palm crashed when launched from Startup Items. I rebooted and the same thing occurred (and Disk First Aid launched and corrected errors during startup). I was getting frustrated. I restarted again (Both times by holding down the power key) and launched Conflict Catcher before startup. I tried different sets and narrowed the problem down to just the Startup Items. So, I got launched and searched the net.
No problems like mine anywhere. Nothing at the sites.
I decided to restore my disk.
Now I've got bigger problems. I was able to replace the System folder (Retrospect did not compare files, it created a new folder with old files in it and I renamed the OS X modified system folder and trashed it after restarting) from the backup set. I trashed the Unix files and searched for any hidden files with a mod date of the installation and trashed them.
I've got OS 9 back to where it was, but...
the OS X bootloader still launches at startup when the option key is down.
How did I think to look for it? I can't startup from my OS 9 CD or my NUM CD.
They both have OS 9.0 on them, not 9.04.
I believe I read somewhere that when OS X is installed, only OS 9.04 CDs can be used to boot.
I tried burning a CD with NUM and my 9.04 system folder on it, but my machine will only read it when already booted (either DVD drive or Firewire). It says it's not a valid startup disk when I try that control panel in 9.04 and select the burned CD.
Now I can't do a full restore, initialization or anything because I can't boot off CD.
I'm considering rerunning the OS X installer yet again, but want feedback first.
This message summarizes approximately 11 hours of work trying to get my system to run OS X.
Any question feel free to ask.
Thanks,
Brandon Potter
 

LunaMorena

Registered
1) The OS bootloader is standard on every mac release since the original iBooks came out a year ago. This includes your iMac. That's why the option key still works.

2) The boot loader does NOT work to boot to OS X if you were running OS 9 prior, nor does it work to boot to OS 9 from OS X if they are installed on the same partition.

3) If you really want to make sure you've got rid of all your OS X files, you probably should initialize the drive and then restore your backup again. While you're at it, put it in two partitions if you want to have another go at OS X. It really does run smoother if it's on its own partition. Also easier to get rid of without messing up your OS 9 files if you decide you still don't like it.
 

BrandonP

Registered
Okay,
I'd like to initialize the harddrive, but I can't boot on my two CD's that System Folders. OS 9 and NUM both have 9.0. Before this mess started I could launch them (I just ran speed disk from CD about four weeks ago).
As far as I know I can't initialize the harddrive without booting from CD.
The OS X installer CD won't be sufficient because you have to have OS 9 installed first.
???
Thx
 

LunaMorena

Registered
Can you currently boot to OS 9? If you can, try putting in an OS 9 CD (preferably one that came with your computer if it came with 9 installed) when it's booted to 9 and then selecting the CD in the Startup Disk control panel. I wouldn't count on any burned CD working.
 

BrandonP

Registered
I finally figured out that the problem booting into the OS 9 CD's I've got was a new Firewire device I've gotten in the last week. I unhook it and no problem.
That might the problem with the OS X installer as well. I'm considering unhooking the Firewire device and rerunning the installer. If it works, I've definitely stumbled onto something.
 

BrandonP

Registered
Hey hey,
Unhooking the firewire CD-burner and my USB hub (with my Epson printer and scanner, ZIP, floppy, and Cyborg joystick) allowed the installer to run.
Anyone else have similar experience?
Thx
 
Top