Installation woes


I tried installing OS X v10.0.3 on my 333MHz iMac. As I was clicking through the license agreements, etc., what appeared to be a UNIX command line appeared on top of the installation screen. I could still see most of the installation screen, but the UNIX stuff left me no option (known to me) other than to press the 'r' key to restart. Upon restarting, the computer would not get past the Happy Mac screen. If I try to restart from the HD, I get the flashing system folder icon. I have tried booting from an old OS 9.0 CD to no avail - the screen remains grey and nothing shows up. Upon attempting the installation, I was running Mac OS Z1-9.1. I've tried booting from an older Norton disc, and that doesn't work either. One additional note, when attempting to boot from the OS X CD, or anything else for that matter, neither the keyboard or mouse responds. Anyone have any clue how I can at the very least boot up to recover the stuff on my HD. Thanks in advance.

I have a G4 PCI (first model) with 256Mo RAM and lot of Go of free disk and it does me exactly the same. The CD boot unable my mouse & keyboard, the little disk is floating and past a certain amount of time the CD drive stops... :(
I wonder if it's not a problem of FIRMWARE or something but there is no update on apple care or i didn't find it. The only one i found is 4.18 for G4 with AGP not PCI...

My computer has 2 MACOS in fact, one MACOS 8.6 on the primary disk and MACOS 9.2 on another disk.

Hope someone has a solution!
The UNIX command line that appeared was actually the remnants of what's called a "kernel panic". This means that something happened that totally flummoxed the kernel (the very most basic part of the operating system) and caused it to vomit up some nasty message and put that command line there. Try zapping your PRAM (hold down command-option-p-r just after the startup "bwoooaaaahh" sound... If you do it right, the computer will restart and you'll hear the noise again. Do that a couple of times, then let go and let it start normally) and if that doesn't fix it, try holding down the Option key during startup. Holding that down tries to make the computer start from os 9. (In the os X help, it's listed as Option: Select a start up disk (on some computers)). If that doesn't work, try starting up from the OS X cd again, holding down C as usual. If that doesn't work, sacrifice a chicken in a Voodoo ritual. Some say that a goat works equally well.

Thanks for the suggestions. I think I have narrowed down the problem. I took my hard drive out of my iMac and installed it in another iMac. At this point I was able to run Norton and some major errors were fixed. Thinking I had solved the problem, I put my HD back in my iMac only to see the system folder icon immediately upon turning the computer on. At this pointit seems as though there is a firmware problem because I still cannont boot up from any CD. The OS X CD comes closest to starting the computer, but it is still hanging up on the Happy Mac screen with the spinning rainbow disk. Does anyone know how I can rectify this problem? Thanks in advance.

Well the diagnosis is correct. A kernel panic is when the kernel of the OS receives an instruction in an unexpected format or that it fails to handle properly. This can be caused by external devices as well.

First thing we should do is remove all external devices including the mouse, keyboard, hub, ethernet cable, etc. and see if it boots up without error.

If not, reconnect the keyboard and mouse and boot up from the OS X install CD disk and from the Installer, choose disk utilities and run Disk First Aid. Restart and see if that cleared up the problem.

If not, shutdown and remove any non-apple RAM. OS X will still boot with only 64Mb of RAM, but it will be very slow.

If this clears it up, contact the manufacturer of your RAM. I have yet to heard of a manufacturer who wouldn't replace RAM that didn't meet Apple specs.

If this still hasn't gotten it, try re-installing. The best method would be to erase and re-install, so I'd boot from a Mac OS 9 CD and back up data first, then erase and install.

If this doesn't work, let me know.

Hope this helps

The memory was in fact the problem. I have no idea where I bought the RAM from, but it's cheap enough nowadays to simply replace it. My question is whether you know whether this was simply an incompatiblity issue, or if the memory was some how damaged during the attempted installation that resulted in a kernal panic. Thanks for any help on this topic.