Installer freezes on iMac


When I boot from the MacOS X Beta installer CD, the CD drive makes much noise and eventually a window that says "Preparing installation. . ." come up. This has a progress bar with diagonal lines that move for a few seconds, and then the CD spins down and the system freezes.

Here are my System specs:

slot load iMac 350 MHz
MacOS 9.0.4 and PowerPC enabler 9.0.4
192 MB RAM
Have installed Firmware update 2.4
MacOS ROM file version 3.7

The only peripherals other than the orignal keyboard and mouse are an Imation Superdisk, and I have tried it without this attached.

I have also repartioned the hard disk as two 3.16 Gig partitions and reinstalled OS 9, and the problem still persists.

<b>Update:</b> I tried booting from the OS X CD in verbose mode to see if that offered any clues. There was something strange looking at the very end:
/etc/rc: command not found: getopt [42]

Automatic reboot in progress
resetting IOCatalogue
kmod create ATIR128 (id 1), 23 pages loaded at 0x62ea00, header size 0x1000
ATIR128::start: starting
ATIR128: using AGP
ATIR128: Unsupported Color Mode

Then it apparently loads the GUI, and freezes in the same place as before.
Does anyone know if this 'getopt' message is normal?
Also, I thought the video card was PCI, not AGP (although I could be wrong about this. It is the stock video card, however). Regardless of that, why should thousands of colors at 800x600, 95 Hz, be an unsupported color mode?

If anyone could shed some light on this, I would appreciate it much.

[Edited by dsnyder on 10-03-2000 at 03:11 PM]
I pulled the stock 64 MB DIMM out of the iMac, leaving the new 128 MB DIMM I got a couple of weeks ago.

Now the installer is working fine!

Odd that OS 9 had no problems with this DIMM, and Techtool's memory test didn't come up with any problems.
Originally posted by dsnyder
I pulled the stock 64 MB DIMM out of the iMac, leaving the new 128 MB DIMM I got a couple of weeks ago.
Now the installer is working fine!
Did you report it to apple?
Let them know the serienr. or something of the RAM module. There are some type identifiers and so on, on the module.
Give a precice description of your iMac aswell. Like you did here
Reported it to Apple this morning.

FYI, here are the identifiers on the offending DIMM:

Hyundai 9934 Korea
Now I'm not so sure that the RAM was actually the problem.

After using OS X for several days, I found that it typically can't go for more than 30 minutes without freezing up, which requires a restart. Eventually, it got to the point where it would always freeze on startup when it got to "Starting Application Services." If I started in verbose mode, it would start without problems. Now, I've found that even if I do start up in verbose mode, I can't login using the GUI as any user. If I login as >console instead, then I can log in as any user, but without the GUI. I've booted into single user and run filesystem checks, and it came up with a bad B tree header, which it claims to have repaired.

So, I decided to reinstall, and now I am having the problem with the installer freezing again.
You should have taken out the NON STOCK MEMORY. This has cured the installation problems with not just my PowerBook, but with several other types of macs who have had installation problems. Sure X is slow on 64MB but it runs solid and hasn't crashed yet in X. (No forced restarts). And from what I gather the problem is with incompatiable memory types, like different speed code and clock rates of each type of 144PIN-DIMMs that are used. Have fun.
Thanks for the suggestion, but I've already tried that as well. I think I'm going to give up on X for now.
Since it's on a slightly different machine, I'm posting a new thread about my problem, but it relates to this one. Some definite similarities (but I just have the factory RAM in my machine).
The iMac started acting up under OS 9, so I sent it for repair and the logic board was replaced. All is well now.