Intellimouse and google conflict?


This is a weird one!

I have the wireless intellimouse and have configured the right button to work as an "open link in new tab" function in Safari. Its worked fine for months. Just recently and ONLY with google (no really!), when I right click on a google found link the page opens in a new tab but ALSO in the current google page. I'm now used to scanning the google results and right clicking on anything that looks relevant and then going through all the tabbed pages later. can't do this as easily now.

Command-left click still works fine to open a page in a new tab. yet I configured the mouse to perform this "key stroke" in the MSmouse prefs.

Anyone else found this?

Using 10.4.2 on a 1GHz angle-poise iMac.
In google check its preferences wether you have this field in

"Results Window" "Open search results in a new browser window." activated or not and check if you see a difference

hope this helps
Like your thinking Gig,
Just tried your suggestion. I activated "click search result to open link in new page" (or whatever its phrased as) and now when I left click a link it opens in a new window (as expected) but the original google window also goes to that page too!!! The right button click set to command click still does the same. Its only google doing this.

Firefox works as expected with google - no problems there.
Google issue only on safari.
I deleted any google cookie I could find.

doing a "proper" command left-click works just fine. Its just the intellimouse version of this that doesn't work (ie I set command left-click to be activated on a right click)
Any further ideas folks?
yes, your set-up works for me too. If right click is set to bring up a "contextual menu" as in the way control-click does I can select "open link in new tab" and expected behaviour occurs. its just when I set my right button to perform a command-click things go wrong:-(

I've just updated the mouse driver app too and no change.
I'm thinking bug or google/safari/intellimouse conflict. I'm blaming Safari as firefox works fine.