Internal Iomega zip

Bilgola

Registered
Hi, I'm new to this forum and in fact new to OSX (but with a fair bit of experience on other Mac OS).

My problems are these. I have recently aquired a PPCG4 (Quicksilver 2002) 933mhz, running 10.2.8. It comes with Superdrive which works fine and an internal zip drive which doesn't work at all. I think this drive might be a 250 but I'm not sure. I've been searching for OSX drivers but am getting confusing answers...like they are not available. This seems strange to me.
When I first got the Mac I put a zip cartridge in expecting to see it pop up on my desktop but nothing happened. Next I tried to eject it but couldn't...as far as I can see there is not a tiny hole for the trusty paper clip method of ejection. So my machine now has a zip cartridge stuck in it. Two questions, how do I get it out? and, are drivers available for my machine?

The other issue relates to Firewire. I have a brand spanking new LaCie (Porche model) DVD burner which worked fine as a CD burner on my earlier G3 but cannot be seen by my G4. Doesn't matter which of the two Firewire ports I plug it into when I try to burn with Toast Pro it tells me there is no media to burn to. When I check via system profiler it tells me that there are no Firewire devices connected. To me it seems that I may have a problem with the firewire connection but I have no other Firewire devices to check it out with. On the other hand it could be a driver thing...but LaCie here in Oz have not been that helpful. Any ideas would be really appreciated.

Kind Regards,

Mike
 

MisterMe

Registered
MacOS X 10.0-10.4.2 supports ZIP drives. The fact you are having trouble with your ZIP drive and and your optical drive suggest that your computer may have some motherboard issues. If you can, ask the person who sold the computer to you about these problems. However, you will probably have to take it to your nearly service center for repairs.
 

Cheryl

Rosie Moderator
Staff member
Mod
Welcome to our forums ! :)

The internal zip is a 250 MB.

Go here for IomegaWare
http://www.macupdate.com/info.php/id/2775

Once installed, The drive should show up. If not, go to Disk Utility (Applications>Utilities). The zip disk should show up in the side bar. Click on it, then in the First Aid tab, have it repair drive, then repair permissions.

It now should show up.

I had a problem with one of my zip disks. I switched from IomegaWare to Disk Utility a couple of times, and it did eventually show up in Disk Utility and I was able to repair the disk.

As for the DVD burner - what version of Toast do you have? It is the latest version that supports DVD burning.
 
Top