internal speakers stopped working

kaprhys

Registered
Two days ago for a reason I don't know, the internal speakers and microphone on my MacBook Air stopped working. I was trying to call on Skype, which I've had on my Mac for years, if that helps figure it out. I know nearly zip about how to fix this thing but I at least figured out by going to Systems Preferences - Sound, that there is no "built-in" option anymore under Output nor Imput, which I suppose must have been there when I could hear anything. My brother says to find the sound driver but I've spent a long time trying to figure this out and can't. When it happened it kept trying to get me to use a Bluetooth but I bought a Bluetooth device several months ago and immediately hated it and don't want to or remember how to use it anymore. I want to use my internal speakers and mic! Please help!
 

Doctor X

Registered
1. Deep breath:


2. Back Up/Clone your internal HD: You should be doing this anyways. The reason for this is if ANYTHING recommended screws anything up you can always go back. If you need further information on that, we can help you. However, you should have an Huge-Ass External HD and a cloning program like SuperDuper! or Carbon Copy Cloner. Time Machine I think now creates bootable clones. Why is this important? You may need to reload your OS--clean instal. Should not affect your data, but what if Gnomes attack?

3. Give the Full Specs: of your machine--look at my signature--need that information. For example, a few OS's ago there use to be this issue with defaulting to "Sound Flower" which meant just about everyone's Macbooks stopped producing sound.
Fix was simple.

4. Screen Shot: post one of your Preference Panel like . . . this:

Preference.jpeg

This may give a Guru some ideas.

There are a bunch of suggestions I could give, but I would prefer to give them after I know you have your data preserved. :)

--J.D.
 

simbalala

Registered
What version OS are you running?

I ran into this problem on an old machine running OSX 10.5 and the fix was simple. Opening the Speech Pref Pane and clicking the Calibrate button turned everything on again. Not sure why but it worked, found the solution via Google.
 
Last edited:
Top