Internet Connect

Dekatophil

Registered
Wasn't able to get hold of 10.1 yet.
I wonder whether they did anything with "Internet Connect", in my eyes the worst app in the whole of OS X.
Why, it normally takes 15-20 tries for me to get online. This may be my ISP's fault, it has also sth. to do with the poor quality of my telephone line. Okay.
But why the heck does IC stop short every time it doesn't detect a carrier ?
It pops up an annoying error message "No carrier detected" aut sim. For ... sake I know that ! Just keep on trying. It's such a waste of time, because it means I have to stay in front of the computer, click away the error message and reconnect. Isn't there a way to make it do so automatically ? I guess it wd be only obvious and natural to let the app try until it does connect. After all, if I say "connect" that's probably what I'd like to do. Why this idiotic error messages ? They belong in the log file. It's really hard to believe for me that Apple have build such a crappy app. The Mac is all about convenience clever design, functionality. And they do a great job at that, normally. I do not know who has thrown together that app, but it's most certainly the worst of it's kind I've ever seen and probably the worst thinkable. Does anybody have a work around for that ?
For the future, I'd ask Apple to concern themselves just a little bit more with us poor dial-uppers... :(
 

AdmiralAK

Simply Daemonic
In 10.1 there is a menuling (right next to the time) that you can use to dial up ;)

As for the carrier problem, make sure that you dont have "detect carrier" checked. If you do it tried to detect a carrier before dialing.

As for 15-20 tries to connect...cant help you there. Might be your ISP. My ISP gives me weird errors like authentication error from time to time and I do not know why. Usually its fixed by rebooting. Oh well ;) at least I know how to fix it.
 
I agree Internet Connect sucks! For 10.0.4 there is a Freeware app called PPP Monitor. This is a great little app and can be found at http://www.versiontracker.com/macosx/index.shtml However it has not been updated for 10.1 yet. I hope it is soon.

AdmiralAK - I didn't realize there is a menuling for IC. How did you get it to appear?

Britney
 

AdmiralAK

Simply Daemonic
Open the control panels and go into networking. There is a checkbox to have it show up in the menu bar.
 

CEMatt

Registered
Strange...I was just fixing to post the question of why I could connect so much better with 10.0.4 than under 9.2.1.

I use the ISP, EarthLink, and it is frustrating how many times I have to redial to get a connection when booted from OS 9.2.1...yet when I boot my OS 10.0.4 partition, an Earthlink connection is ALWAYS made on the first attempt...not only that, but the connection stays made even when I'm idle...a complete puzzle to me.

I have a G4/466/512MB RAM and was about ready to drop Earthlink until I noted how well it worked under OSX. I am almost afraid to post this for fear my bubble will burst. :D

Matt
 

Dekatophil

Registered
AdmiralAK, thanks for the tip. Where can I disable the "detect carrier option" ?
You know, what really annoys me is that completely pointless popping up of error messages. It shd just stay on trying.
Britney F. thanks for the link ! I'll definitely check it out.
:cool:
 

AdmiralAK

Simply Daemonic
I am not on an OS X machine now so I will try to do this from memory :p
Go into the control pane and go into network. There is a button caller prefs or options in the same place where you choose your modem type. Click on the options button and that is where the disable carrier detection is located (its the same palce where you set redialing options)

Hope this helps

Admiral
 

Dekatophil

Registered
I'm afraid there is no such option. I can see the redial options and all. Nothing about "carrier" though. I'm still on a 10.4 machine. Maybe the "disable carrier" option has only been added later ?
 

Dekatophil

Registered
Upgraded to 10.1 now. Still no "carrier" option (network prefs/ PPP/ Options).
Again redial etc is there, but nothing about the carrier.
Admiral ?
 

monty

Registered
I don't know about 10.1 (still waiting for my copy) but in 10.0 it's:
System Preferences - Network - Configure: port name - Modem - Wait for dial tone before dialling.

Hope this helps.
 

ntsc

Registered
Has that annoying freeze bug thing been fixed in 10.1, where the whole machine would lock up for upto 5mins b4 it would connect?
 

mailseth

Registered
I have had it lock up for about 5 secs before (in 10.1 on an iMac)

:(
 
L

laibukki

Guest
Thank you monty. I disabled the dial tone thing. However, I still seem to get those funny error messages. Have to talk to my ISP. Last Sunday I gave it 50 (!) tries, but no way to connect. Then I switched to an alternative provider and -voilà_ the first attempt got me connected. I need to talk to my ISP:mad:

Well, as for the freeze, yes that happened under 10.1, too. But only for like 1 minute or so. After the first restart that freeze disappeared. :)
 

AdmiralAK

Simply Daemonic
lol I have not been to this thread in ages
Sorry guys, didnt mean to blow you off:rolleyes:

System Preferences - Network - Configure: port name - Modem - Wait for dial
tone before dialling.
that was what I was talking about:rolleyes:

Next time I need to choose my words more carefully :p
 

Dekatophil

Registered
Fair enough.
Problem didn't go away though. Haven't been able to connect to my ISP recently at all. Tried an alternative ISP and got connected right away.
Man, somebody's gonna have it... :D
 

homer

Safety Inspector
I'm new, just registered, and this Internet Connect thing interested me. I upgraded to 10.1 from 10.0.4, and right away my modem script wouldn't work. I had been using the apple internal modem v.90 script, but it wouldn't connect for me. I dropped it down to v.34, which still wouldn't work. I chose some others, and finally the Apple GV Modem script worked. However, most of the time it says that I'm connected at 0 bps. I'm getting reasonable download speeds, and can connect almost every time, but I'm curious as to whether anyone else has encountered this problem.

homer
 

AdmiralAK

Simply Daemonic
I had the same experience and I do not know why.
ALl is fixed though ;) ...waiting for some newer version of web browsers as well as an OS X version of Yahoo Messenger ;)


Admiral
 
Top