Internet Connection in X 10.1

eric halfabee

You talking to me!
Basically I cannot connect to the internet after upgrading to 10.1 on my new Quicksilver 733. Although I can connect to my LAN.

G4 733 with 1 x 40 GB partitioned into 20 GB for OS X and 20 GB for 9.2.1, plus 1 x 9 GB for other stuff.
640 MB RAM
Ethernet 100BaseT connection
DSL internet connection to our ISP (
Network setting: DHCP Server, Ethernet connection, AppleTalk on...

The background:

Up until last week I was running 10.1 on my old G4 400 PCI mac. This had problems connecting to the internet as well but was intermitent, I would manage to get a connection after I would rearrange the network settings back and forth and log back in.

So I recieved my new G4 with 9.2.1 and 10.0.4 preloaded on one 40 GB partition as is the norm. So after awhile of just playing about checking out the speed and what not, I logged into X and everything was OK, internet connection and all. OK now for some work, I installed all of my work from backup and reinstalled my OS 9x applications and settings, everything OK so far. I then decided to upgrade to X 10.1, no problem with the upgrade and everything seemed sweet – until I tried to connect to the internet.

I checked and rechecked my network settings, they looked the same, I rebooted many times, but to no avail. Well they say its best to partition your drive so I did (setup as above), still no joy, its funny though as I have ethernet connection to our macs on the LAN via appletalk, (I also have the latest software updates from Apple).

If someone can shed some light on this problem I would be most grateful.

If you need more info please note that I am in New Zealand so there will be a bit of a time difference.

Thanks in advance

eric halfabee



Official visitor
Please describe your network...

Could it be that you have not specified any domain name server in the Network pane ?

On my Macs, everything works well...


mach-o mach-o man
yeah, like pascal said, we need to know if you are behind any proxies or firewalls. Information on your external router would also be usefull.

BTW, while your at it, fire up the terminal (/Applications/Utilities). Try a few things:

1) dns test.
type nslookup and post the output.
2) other dns test (this one tries every dns method on the computer, the above only tried the default).
type host (use a different host for every test, just incase your results are cached). Post this output, too.

3) traceroute.
traceroute (substitute with your isp's domain.)
4) trace route again!
traceroute hostthatworks (substitute hostthatworks with a host on your network that you have access to.)

5) if you are not getting errors, attempt to ping some of the hosts you can't reach.
ping host (where host is a host you are unable to access in a web browser under 10.1).

6) if you can hostlookup, traceroute, and ping a host, something quite odd is wrong. So try and access a webpage from the command line (in the terminal).
you should see a large amount of html. Thats good.

So, run these tests, and post your results. You can summerize last one (ie, say if there was html, and if there wasn't, say what happened).

Hope this helps. Remember, with every 10.1 purchase (and new cpu pruchase), there is 30days tech support from apple, just call em and ask away! And do post your results.

eric halfabee

You talking to me!
To Pascal and Kilowatt

Thanks for your help, sorry for taking so long to reply, but I have managed to get it sorted out.

Now I'm not sure what exactly caused/causes this but what was happening is that OS X couldn't automatically see my router using the 'Using DHCP' option, or the 'Manually using DHCP router' option. So I had to select 'manually' and enter the addresses for 'IP', 'subnet mask' and 'router' as well as the DNS addresses.

I found this out (well a tech head friend of mine at Uni did) by pinging co-workers on my LAN and also a address on the net. I was getting results for the LAN because I had enabled AppleTalk.

Anyway it works but still not sure whats causing the other options to not work.

Thanx again.