Iomega Cdrw55292ext And Mac Osx


I have an ibook g3 running OSX 10.3.9 and I am trying to use an Iomega External USB CD-RW. Unfortunately, if I try to insert a blank disk into the drive and select to open Finder, I get an error message "Could not burn CD Because there is a problem with the drive. Error 0X80020023." Then the drive freezes so that you cannot even eject the disk. I read elsewhere that setting OSX to ignore blank CDs helps, but once you set OSX to ignore blank cds, you can't use Disk Utility to make restores or burn using itunes. Also, I have tried freeware products like PatchBurn to try and fix the problem with no luck. I tried contacting both Apple and Iomega. Neither have a clue.


Was this problem ever solved? I am trying to burn an iMovie project using iDVD and keep getting same message and same frozen drive problem. I have a G4 flat screen iMac 800Mhz running 10.3.9, iDVD 3.0.1 and iMovie 3.0.3. Have tried repairing disk permissions and searched everywhere for an answer but no luck yet. Have also tried different disk makes and types including TDK DVD-RW and BEST DVD-R to no avail. Any suggestions welcome!