iphoto not recognizing cybershot camera

direwolf2

Registered
g4 powerbook does not mount/recognize sony cybershot camera for importing images; recent upgrade to osx 10.4 from osx 10.2.8 - all worked fine before?

any insights or solutions - as have important pics to save - tried the forums, but got lost
--direwolf2
 

Madelin

Registered
What model of cybershot?

Complete guess here but is there anyway to put the camera into a 'disk mode'. Try plug it into the mac then.

Looking over the forums there are a couple of tips.
1) Repair the permissions and try again.
2) Update the drivers if necessary on your mac by going to this site

Forum search for cybershot : http://macosx.com/topics/cybershot.html
 

acepress

Registered
Dont know if this will help..I am on same system, all I have to do is turn on the camera, connect it to computer via usb cable and instantly the folder iwth my new pix shows on desktop, I drag them to my Desktop to copy them....maybe THEN you can get them into iphoto...
 

sgould

Registered
I had a similar problem with my Sony DSC-T1. Sony had a firmware upgrade that solved it.

If that doesn't work. Check the application "Image Capture". You normally won't know it's there or loaded. This is the software that the Mac uses to recognise your camera when attached and then opens iPhoto for you. If the preferences have changed it my not be either looking for a camera or opening iPhoto.
 

PBear

Registered
Have you tried using a USB memory card reader?
I don't know if this'll help but click on the Desktop, not on a file or folder, then hit the command "⌘" and "," keys (without the quotes) or Finder > Preferences > General tab, choose Hard disks to show on the Desktop.
 
Top