Iphoto Problems


Hi -
When I open my iphoto, it just says "loading photos" but never loads them - help! I can't import from my camera or anything - thanks for the help!!!


Rosie Moderator
Staff member
Your post got put in the wrong forum section, which is why you have not gotten any responses. I have moved your post to the correct section.

The next question is what OS version are you running and what version of iPhoto do you have?

Have you used Disk Utility to repair permissions, then open iPhoto?
Did iPhoto work before this?

Go to Home>Library>Preferences. Trash the com.apple.iPhoto.plist file.
Empty the trash. Now open iPhoto.

Does that correct the problem?


Hi there. Back to the iPhoto problem...Some of the pictures look corrupted, because on the bottom of some there is a gray line or an array of colors in a line. How did this happen? But there are others that appear not to be corrupt and they are all in JPG or GIF format. How do I import the pics thru "the program?" Thanks for all the help. :eek:)


to import the pics best way IMO is to use the "file" > add to library function (cmd-o)


I've run into the same problem (i.e. pictures will not load)... I've tried the suggested remedies (from Cheryl) but same thing happens afterward when I open iPhoto... any other ideas on how I can fix this?

I have iPhoto 4.0.3 and am running OSX. I've been working with this version of iPhoto for about 6 months with no problems prior to this.

Thanks for any suggestions!


The Late: SuperMacMod
Has the iPhoto picture folder or iPhoto application been moved from it's default location?

Here is the standard first aid.

There are several procedures to try. Please try in order. Also, unless otherwise noted make sure you have Quit (closed) iPhoto.

1. Restart your computer to repair the directory if needed.

2. Run "Repair Permissions" from Disk Utility located in your Applications>Utilties Folder.

3. Try iPhoto again. If it doesn't work then QUIT iPhoto.

4. Your iPhoto preferences file may be corrupted.
(MAKE SURE you QUIT iPhoto first)
You will find it in your Home directory:
(Home/your account) >Library>Preferences>com.apple.iPhoto.plist

Remove or trash the preference (.plist file) and restart iPhoto.

If it still doesn't work go on to these remedies, in order.

5. Bad Album data?

1 - move the Albums folder and the AlbumData.xml file to the desktop.
2 - launch iPhoto. It if launches successfully you probably have a corrupt album.

To locate the bad "aibum", do the following:

1 - move one of the individual album folders and it's associated data file into the new Albums folder that was created in the iPhoto Library folder.
2 - launch iPhoto. If it's successful do the same with the next album folder and data file. If iPhoto doesn't launch successfully, that's a bad one and remove it and the data file.
3 - repeat for each individual album folder in the old Albums folder.

6. Rebuild Library
Relaunch while holding down the key combination below for your version
Option+Shift IPHOTO 2
Command+Option+Shift IPHOTO 4
Command+Option IPHOTO 5


bob i followed your instructions (#5 Bad album data), but I didn't find a bad album. I do however have 3 documents left over:
Pending rotation
iPhoto Library
I'm using iPhoto4 4.0.3 & OSX. iPhoto works now, but just asking if I can trash the old albums folder with these documents (if not needed)


The Late: SuperMacMod
Just to be safe, put those files in a folder on your desktop for awhile. If iPhoto continues to work ok, then trash that folder.


Similar problem:
I tried to move the lib to a new drive because my wife's ibook was darn full. Through a series of mishaps iphoto showed all the album names but no photos even when I put the ORIGINAL dir in the ORIGINAL place. Deleting the prefs file fixed my issue. THANKS! I'm a PC guy and was half way round the bend on this.


I have had the same problem with iphoto since I moved around the folders in the library. I left it unfixed for a while because I didn't come across a quick fix and now I am having a further problem. First of all I can't open preview and secondly, when I open iphoto nothing comes up, and when the screen does show it is completely empty. It recognizes my camera when I plug it in, but when I try to upload the pictures nothing happens. I'm using a very old version of iphoto (v. 1.1.1), will I be able to solve these problems better if I update?