Is anyone else having this problem?

MacSub

Saiyan Member
Firewire CDRW sometimes works?! HELP!

In 10.0.4 my firewire CDRW worked well all the time, ever since I installed 10.1 it only works part of the time, infact it hardly ever works. 10.1 just doesnt' recognize it anymore!

I have a new 24X firewire drive from FORMAC.

Anyone have the same drive?
 

ytsurk

Registered
Sorry I can offer any advice -- but I am having a similiar/same problem. I just got my Formac 24X (which I assume is a Sanyo mechanism) and I already had 10.1 installed.

Nothing

Drive does not even appear -- looking in the X.1System Profiler, my entire Firewire bus is not listed. I would think my firewire bus was shot except for the fact that it appears in 9.2.1 sytem profiler (bus only, not the drive). However, it shows "no device connected" to it. I've tried various extension setups, checked the cables, power etc -- no go, this drive is absolutely unrecognized by my system. When I turn it on, it spins up -- so the problem apparently is not inside the drive but somewhere between the firewire bridge in the drive and my firewire port.

Ho hum, this sucks . . . I'll post again if I find a resolution. Please do the same if you can.

One question, if you open your system profiler in X.1, does your system at least see the bus and/or the drive ?
 

genghiscohen

Membrum virile
If you have (or sign up for) a free ADC account, you can try a possible fix here.
 

ytsurk

Registered
Hey, thanks . . . I tried the ADC link to the Firewire SDK. Still can't get the freaking thing to show up in either system but at least I was able to use some of the sample extensions and run the FIWX sample driver AND HAVE IT APPEAR AS A FIREWIRE DEVICE IN THE APPLE SYSTEM PROFILER. So, at least I know (I think) that my firewire bus is intact. The drive itself comes on fine and spins up when I put a disk in it -- so that narrows the problem down to either software OR something between the IDE->Firewire bridge in the writer and the firewire port on my mac.

BTW, yes, I do have Toast preview 2 installed. Also, I did have Toast preview 1 installed for a while (when on 10.4). My understanding is that preview 2 is non-invasive to the system kernel but that preview 1 was (added some sort of kernel extension, if I remember correctly). I'm sure I just threw prev 1 in the trash w/o fully deleting whatever it added to the kernel. There definitely could be lingering elements of it in my system. Any idea how to get rid of it ?

I wonder if the 10.1 update somehow failed to install proper firewire support because Toast PR 1 stuff was in the way.

Thank you both for your assistance . . . I'm determined to exhaust every avenue so I can avoid the whole "returned merchandise" pain-in-the-neck.
 
Top