Is there an issue connecting to an 0S9 server via tiger?


I guess the title says it all...

i went to a client today that have a few servers,one of them is an old G4 server running OS9.2.2 with some sort of server client, this is being used as a file server.

Here is the problem,theers a lot of Macs in the building mainly old OS9 Macs that can connect fine to this server,there is also one quite newish eMAc that is running 10.3.5 that can also authenticate fine,but if I try ro connect to via the Tiger OS based machine and "NO".
It can see the server but when I try to connect I get an eror message telling me that the server is no longer avalable,check the IP address or check that the name hasnt changed,neither havent.
Tried the usual way of connecting via network and go to server using both the name and IP address but no joy.

I can ping the ip address so it knows it is on the network.

Any ideas? I have tried variious troubleshooting (repairing preferences checking logs,repairing directory (which I couldnt due to lack of disk space) etc etc but nothing.

Is there a plist file somewhere that could be causing this? or am I looking at a corrupt directory file? or is it just not compatible? AAAHHHHHH!!!!