Isync Nokia 6630


I am running tiger 10.4.2 on a 1.5 ghz G4 powerbook. I upgraded to I sync 2 in order to sync my nokia 6630 and it worked for a while. Then a problem developped on my phone so I formatted the memory card on the phone. When i came to reinstall the apple sync agent it kept generating a corrupt file that it sent to the phone. So i tried restarting both devices but still corrupt file. My next option was to uninstall isync and reinstall it maybe that would resolve the glitch. I couldn't find the means to uninstall i sync, so I did the unthinkable and deleted it manually by searching for all instances of I sync. then I came to reinstall isync 2 and it kept giving me an error, presumably cause it is an update, and thus requires the original isync to update. I proceeded to dowload I sync 1 and 1.5 and then upgraded to isync 2, it says installation succesful but now when I launch it, the window looks funny, icons are not well alligned, and it only shows me .mac, when I try to add device, it does not find my phone. Although i can find it in my bluetooth device manager. So Now I think i need to uninstall i sync and look for a full install of Isync 2. Can you please help me.