Its Back. (ppp issues)


Ok it came back. My locked up computer with jittery mouse movement when i'm connecting to the internet. It happens after i select 'connect' and before the dial tone starts up. Last night it happed for about 30 seconds. It doesnt always do it. But once it starts it just gets worse and worse every time i try and connect. I though this was to be fixed in 10.1.

Anyone else having the same problem?

i am having the exact same problem. i thought it had gone away with .1 but it came back yesterday. what sort of system and modem do you have ?.
i am on a G3 333mhz, 384 MB, using a Global Village modem.
anyone with any ideas of a way to stop this from happening please post it
I'm still having this problem in 10.1, too. Once, when I tried to dial-up immediately after logging in to OS X from the login window, it locked up my system for 5 minutes and locked it up so completely, the spinning beach ball stopped spinning. I ended up restarting (and ruining a long uptime...I hate it when that happens!)

One thing I've noticed in top...under 10.0.4, it was usually configd (if I remember correctly) that was eating 98% of the processor time during the lockups. Now, it's pppd. Seems to me that Apple has moved the problem instead of fixing it.

At any case, the problem does seem to occur slightly less often in 10.1 than in 10.0.4.
I'm running a G3 350 B&W tower with a build in 56K modem. Lots o' memory.

For a system that supposedly never needs re-starting we sure are getting screwed. Thats the only way to fix this problem.

I have the same problem. I didn't always have it. It started happening relatively recently. Maybe after upgrading from 10.0.3 to 10.0.4?

I'm using a standard Apple modem.

I've tried changing some options in my PPP control panel, but because the problem is intermittent, it's hard to know if I've fixed anything.

Andrew Montague
Same problem here. :(

I have an iBook 500 DVD w/640mb ram. The problem was really annoying on 10.0.4. Once, it froze the iBook for almost 10 minutes. When I upgraded to 10.1 it seemed to have gone away. Then I noticed it was still there, but now it only makes the mouse pointer jump around for less than 5 seconds. I only got a delay of about 1 minute once on 10.1, but it's still a VERY annoying problem in a system that's supposed to allow full multi-tasking! :mad:
I've disabled verbose logging in the PPP options (on the ppp tab) of the network control panel. Since doing this, I've not had the problem. However, as the problem is intermittent, it's difficult to say whether this is really a solution.

Andrew Montague
Originally posted by andrewmontague
I've disabled verbose logging in the PPP options (on the ppp tab) of the network control panel. Since doing this, I've not had the problem. However, as the problem is intermittent, it's difficult to say whether this is really a solution.
I guess it isn't. Just done that, and the problem persists. It didn't make a difference whatsoever. It seems to be all fine when I startup the iBook and then, the longer the uptime, the worse it gets. Also, sometimes it gets worse when I wake up the iBook from sleep. But then other times sleeping doesn't make it worse! I don't get it... either several modems are screwed up or the modem driver eats up all that cpu when we try to connect! Either way, it's a pain in the A**!! :(
Happens to me too. You're close on the 'modem driver eating up all the cpu' - this is happening because the connection script (and pppd and CCLEngine) are waiting for the modem to power on. When you disconnect, one of the last things it tells the modem is to power down. So we get this nice wait while the modem powers back up. :rolleyes:
Do you have the option checked that says to connect automatically when a TCP app is run? (Or something to that effect.)

When I turned that off it quit doing what you are talking about on my ibook. I always turn on internet connect before I open mail app, entourage or internet explorer, etc. Just a thought.

I also do not let my mail app go after mail automatically (unless I know that I will be constantly online) or I lose control of my mouse all of a sudden when it goes after it. I set my mail apps to go after mail manually.
i have started to delete my ppp.log from my tmp directory and it seems to be working so far. (so far being today...)
"sudo rm /private/tmp/ppp.log "
it is faster than restarting which is what i have to do to stop my mac from locking up when i try to connect.
I always keep "automatically connect to Internet" off, and I still have the problem.

I don't think that opening Internet Connect instead of using the menu bar connect makes any difference. I always used Internet Connect under 10.0.4 and still had the problem.
Following up on gigi's post, I checked my ppp.log file after the latest lockup. The log had the following in it after the termination of the previous connection:

CCLWrite : +++
CCLWrite : ATH\13
CCLMatched : OK\13\10
CCLWrite : AT&F\13
CCLMatched : OK\13\10
Serial link disconnected.
CCLWrite : AT\13
CCLMatched : OK\13\10
CCLWrite : ATI4\13
CCLMatched : Apple Internal Modem\13\10
CCLWrite : ATI12\13
CCLMatched : S1\13\10
CCLWrite : AT&FL3E0Q0V1X4&C1&K3S95=1&D3S7=75S0=0W2\13
CCLMatched : OK\13\10
CCLWrite : ATM0\13
CCLMatched : OK\13\10
Dialing 8,695-8888
CCLWrite : ATDT8,695-8888\13

During most ppp.log entries, the various CCL lines do not appear before "dialing." The first entry after termination of the previous connections is the line "Dialing."

So, what is CCL? Something to do with communication with the modem? Why does it get to hog the processor?
I am so F**KING P**SED OFF......
please ignore my "delete the ppp.log" doesnt do anything except give you false hope. i have just got another 2 minute "freeze". 2 minutes may not seem a long time to those of you not suffering from this problem but when you have to wait out the 2 mins, it seems like forever.

Tom C my ppp.logs are similar to your

"CCLWrite : AT\13
CCLMatched : OK\13\10
CCLWrite : AT&F1E0W2S95=45S0=0&D3S7=60\13
CCLMatched : OK\13\10
CCLWrite : ATM0\13
CCLMatched : OK\13\10
Dialing without tone
CCLWrite : ATX1S6=4\13
CCLMatched : OK\13\10
Dialing 1891 121 121
CCLWrite : ATDT1891 121 121\13
CCLMatched : 48000
CCLMatched : \10
Serial connection established.
using link 0
Using interface ppp0
Connect: ppp0 <--> /dev/cu.modem"

sadly i guess its back to OS 9, just cant bare the wait.
Well, let's see if we can narrow this problem down...

1) Is there anyone using modem dial-ups on OS X who has NOT experienced this problem? If so, perhaps the problem is specific to certain hardware. What kind of hardware are people who have/don't have the problem using? I have an iBook 2001, with Apple Internal Modem 56K v.90.

2) Has anyone noticed any circumstances under which the problem is more likely to appear? I find the problem more likely if I've logged out of OS X and logged back in, but this is by no means the only circumstance under which the problem appears.

I still wish that I knew what CCL is...
i'm on a G3 350 w/56K built in modem. Strait from apple back in the day. It seems to happen after a few times of connecting to the internet. But i did notice last night that when i loged out as user 1 and in as user 2 it worked fine. I think it has to do with how many times you connect to the internet. Like for some reason that on the 5th connection it starts freaking out and every time after that it freaks out a little more. Maybe internet connects memory is only so big and after a while it just cant think any more.

I really have no idea.
Forget the previous posts about the ppp.log...

My recent log-ins have been fine without a lockup, and the CCL stuff is still in the log. I have no ideda why sometimes it logs the CCL stuff, and sometimes it doesn't. My past 4 or 5 logins, it has done so; before that, there were 20 or so logins where it didn't do so, and before that, there were more logins when it did log the CCL stuff.

The CCL lines contain Hayes-compatible commands to the modem.
It happens on my B+W G3 350 MHz with standard Apple G3 internal modem.

I haven't noticed it happening more often after sleeping, but I haven't looked out for that either.

Andrew Montague