iTunes Burns - Finder Won't!


This will be a fairly lengthy post, but I want to provide enough information in case someone is inclined to help ... or if all else fails, Apple decides to provide a bug fix. First, the technical specs of my setup ....

G4 Cube 450 MHz 768 MB RAM
Cyclone CD Revo Firewire 12x-10x-32x CD-RW
(Sanyo CRD-BP1300P Mechanism)
OS X 10.1

As the title indicates, I am able to successfully ... in fact, flawlessly burn audio CDs in iTunes. Unfortunately, I am unable to get my CD-RW drive to burn data CDs in the Finder. Since data CD burning is one of the major features for the OS X 10.1 upgrade, I think it goes without saying that I am extremely disappointed. The following are the symptoms I am experiencing ...

A. The CD-RW drive can read data and audio CDs that are commercially produced. However, it is unable to read CD-R or CD-RW media ... even those that it burned! Whenever I insert a CD-R or CD-RW disc with data, I get the "You have inserted a disk containing no volumes that Mac OS X can read .... blah blah blah." dialog box with the choices of Continue, Initialize, or Eject.

B. If I click the Initialize button in the dialog mentioned above or if I open Disk Utility directly, I can successfully erase a CD-RW.

C. iTunes lists my CD-RW drive in the Advanced tab of its Preferences as "Generic CRD-BP1300P". It will burn an audio CD with no problem, however, as soon as it is done I get the "You have inserted .... Continue, Initialize, Eject" dialog I mentioned earlier. Very strange indeed! OTOH, the internal DVD-ROM on my Cube can read the newly burned CD just fine.

D. I am able to open/close the drive bay on my CD-RW using the Eject key on my Apple Pro keyboard.

E. If I turn the power off on my CD-RW drive and then turn it back on, the Firewire connection does not re-establish itself. If I unplug the Firewire cable in the back of the drive, I consistently get a Kernel Panic! The only way to re-establish the connection is to plug in the cable, turn on the drive, and reboot the computer. In other words, it is no longer "Hot Swappable"! I did not have this problem in OS X 10.0.4.

F. If I insert a blank CD-R or CD-RW disk into my CD-RW drive, I get the "This disk needs to be prepared for burning. Do you want to prepare this disc?" dialog with the choices of Ignore, Eject, or Prepare as expected. (Note: I just noticed that the first sentence says "DISK" whereas the second says "DISC"! What's up with that? Anyway, I digress .... :) ) If I click Prepare the disk spins down and ejects ... but the "Untitled CD" icon mounts on the desktop as expected! Dragging files to this icon and clicking Burn in the Finder prompts me to insert a blank disk. If I do, the whole cycle of "insert disk ... click Prepare ... disk ejects" merely repeats itself.

G. Just for grins, I thought I'd upgrade the firmware on my Cube to the latest version 4.1.9. The Read Me file mentioned something about Firewire and it's generally a good idea to stay up to date anyway. Well, the firmware updated successfully ... but unfortunately this provided no change in the behavior of the CD-RW.

H. The Apple System Profiler in OS X 10.1 is seriously tripping. In fact, when printing a report it says "Version of ASP that generated this report = 2.7. (note: this string only shows up in pre-final or debug versions)". What's up with that on a "final" GM release? I never used it on 10.0.4 so it might have said the same thing in that version of the OS too. Then again, it could be exposing what might be the root of the problem with the OS not supporting my CD-RW. I noticed the following things that ASP in OS X had to say about my hardware setup in the Devices and Volumes tab ....

Firewire 80.0
Vendor ID: 30dd
Speed: 400 mb/sec
GUID: 3202304d
Vendor Name: LSI Logic
Unit Version: 66691

harman/kardon (CRD-BP1300P)
Apple disc burning:Supported
Product ID: 30793 ($7849): SoundSticks
Vendor: Harman International
Driver Version: Not available
Driver name: Not available
Power (mA): 500 ($1f4)
Release number: 80.0<1.02>

Now this is very strange indeed! First of all, my CD-RW drive is hooked up to my Firewire port, not a "CD-ROM". Also, the Vendor of the drive mechanism is Sanyo, and it always says "Generic" in iTunes .... so who the hell is "LSI Logic"? But wait it gets worse! According to ASP the "CRD-BP1300P" is connected to the USB port ... even though it obviously is a Firewire drive. And since when is "Apple disc burning:Supported" on a speaker system? In fact, a lot of the information about my CD-RW drive seems to be intermingled with the SoundSticks information. I see "<Generic>" in the Vendor Name and <1.02> (which is the firmware version number) in the Release Number.

Now compare that to what ASP has to say about my setup in OS 9 ....

Firewire 2.8.4
fw609e, 10483
Revision ID: 1.02
Serial Number: Not available
Product ID: sbp609e,104d8
Vendor Name: Generic
Sub revisionID: Not available

USB 1 1.5.5
HID (SoundSticks)
Product ID: 30793 ($7849)
Vendor: Harman International (harman/kardon) ($5fc)
Driver Version: 1.5.5
Driver Name: USBHIDDriver
Power (mA): 500 ($1f4)
Release number: 0.0.1
Serial number: Not available

I. To top all this off, this CD-RW has always worked for me without a hitch. It worked in OS 9 under iTunes and Disk Burner. And as I mentioned before, it worked in OS X 10.0.4 under iTunes, and currently works in OS X 10.1 under iTunes. In case you are wondering, it was specifically listed as a supported drive in the Read Me files for iTunes 1.1 (OS 9), Disk Burner 1.01 (OS 9) and iTunes 1.1.1 (OS X). Mysteriously, it is not listed in the current list of supported drives at the iTunes website. However, the CRD-BP1400P which is just the 16x-10x-40x version of my CD-RW is listed as supported. So what' up with this? Apple specifically lists my drive as tested and supported in OS 9 and the initial version of OS X, but now it's suddenly no longer on this list? I hope my experience is simply a bug (after all it is partially supported) instead of a case of Apple trying to backtrack on a supported drive!

J. The OS X 10.1 FAQ on the Apple website mentions some extremely vague and utterly useless TIL that says something about contacting the Firewire drive vendor to get a firmware update if the drive doesn't mount. Even though my drive does mount (if I boot up with the drive plugged in and turned on) I decided to look into this anyway. The Cyclone site didn't have any information whatsoever about firmware updates so I did a Google search on the mechanism name and found a Sanyo site that did have firmware updates. But as my luck (or lack thereof) would have it .... the update program only runs on WINDOWS!

So the bottom line is I'm stuck. I've spent hours tinkering with this thing and compiling all the information I posted here. Unfortunately, I'm all tapped out of ideas. If anyone has experienced anything similar please let me know. If anyone has any suggestions to share they would certainly be appreciated.