Jar Launcher Failing


I am a new mac user with an iBook running the newest tiger version. I am trying to open a .jar file, but nothing is happening. It is set to run with JAR Launcher, but even if I use 'open with' it does not work. Do you have any ideas,
Or you could open the terminal (Applications->System Tools->Terminal) and go to the directory with your Jar file and type "java -jar myfile.jar" and see if it runs, and note the error messages if it fails.

You need to remember though, just because it is a Jar doesn't mean it's going to be executable.
I was going nuts trying to open a .jar file that I downloaded from the Azureus site. I kept on getting the same message from Jar Launcher: The jar file "[...].jar" couldn't be launched. Check the Console for possible error messages. I got a similar message when I tried to open several other .jar files I found on my disk. It was that problem that led me to this forum.

I tried re-installing Java, removing the Java Preferences, etc., and nothing worked. Then I noticed, examining the contents of the Azureus application package, that there were a number of .jar files in the various Contents/plugins/az* directories! I probably could have just copied the .jar file to one of those directories, but I went back to Azureus, selected the Plugins -> Installation Wizard ... menu item instead. The rest was trivial!

I wonder if there are any .jar files that really do run by clicking on them in the Finder, or by opening them with something called Jar Launcher that I can't even find on my computer (Tiger 10.4.6)! If so, it's rather misleading to use the same extension for files that can't be opened that way!
I am also inexperienced but have the same problem. I have played Scrabble for years with "wordbiz.jar" but all of a sudden now it will not open. I have tried to reinstall jar launcher but nothing seems to be working. When you said "the rest was trivial" what exactly did you do? Please help.