javac broken by new dev tools

rollerdexter

Registered
It seems I can no longer use javac!
After installing the new dev tools, javac just responds with a:
"Segmentation fault" error, even while trying to do the simplest hello program.
I don't know how to fix this, short of getting a new dev tools and starting over . . .
any ideas?

- miles
 

theolein

Registered
Have you checked the paths? there was a thread on this somewhere here, and there was something about the paths having changed.
 

rollerdexter

Registered
Well, good ol' mac strategy: hit the reboot.
solved the problem. I did notice that I did not have to log
in after the reboot. Seems to skip the log in screen if only one user.
But this seems to also have some bugs. Because something broke
my ability to use the sun javac tool after I logged in the first time (jar worked OK though . . . )
I don't know enough about unix user environments (shells?) to figure this out. I'm just glad its working again.

BTW, I found out that the sun java tools are not installed by the developer tools disk, but by the original installer disk.

- miles
 
Top