JVM Terminated error when starting eclipse 3.1

zepto

Registered
When starting eclipse the first time after installing it all is well, that is the application startsup fine.

However when I close it and open it again I get a JVM termination error. I think it has something to do with 'permissions' as when I run the disk utility and repair the permissions it reports that the JVM location permissions are fixed. It then lauches the first time, but not a second time?

FWIW, I'm running eclipse in a user/Applications folder and the user account permissions are for just a user.

So, I have a working eclipse install providing I run the disk repair utility each time before launching it, but it is a little tedious.

I'm running 10.4.1 with all the security patches etc. applied

Thanks
Zepto
 

pranaykondekar

Registered
Even I was facing same problems for 2 weeks. I tried changing the Java preferences and running eclipse it was not working. At last I found the way to run it.


If you have installed JDK 1.6 on a 32 bit system, eclipse will not work. To remove the JDK 1.6 you need to remove all versions of Java installed on your system. You can remove that using following command.

sudo rm -rf /System/Library/Frameworks/JavaVM.framework/Versions/

Once you remove java, you can check it using the Terminal and giving command
java -version

Now its time to install JDK 1.5 on your system. To get the Java update visit this link and download and Install this update.

http://www.apple.com/support/downloads/javaformacosx105update2.html


Next step is to set default JDK for your system.
Go to Applications->utilities->Java->Java Preferences
Drag J2SE 5.0 (32 bit) to the top level in both Java Applet Version and Java application Version.


Now you all set
Check the current version using java -version command at termnal.
It will show like

java version "1.5.0_16"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_16-b06-284)
Java HotSpot(TM) Client VM (build 1.5.0_16-133, mixed mode, sharing)

Now run eclipse in normal way, it will come up.

Thanks

-Pranay Kondekar
 
Top