LaCie external wont mount...!


I've got a 140 GB La Cie external and all of a sudden it is not recognised by any of my macs. It appears in Disk utility in the side menu but the verify/rapair buttons are greyed out. I've tried Norton, Techtool and Diskwarrior and they can't even see it to repair it. Even tried it on OS9 with norton and no luck - any ideas anyone?

Any help would be great.

I have a similar problem with an external drive: I have an old APS 9 GB SCSI drive with important info I need to download. It worked fine months ago hooked to my iBook using a Microtech SCSI-to-USB adaptor. Now it no longer appears there, so I tried it with my iMac G5. Both Macs have both Microtech extensions installed in OS9 and I switched both to Classic. I also tried unplugging and plugging the USB cable in while the drive was running. After a couple tries it appeared on the iMac desktop, but as 3 identical icons each containing the same folders (no idea why that happened). The drive appears in System Profiler.

Then there was a power outage. When I had power again I tried again but now nothing I try brings the drive up on the desktop. Its green light is on; the red light occasionally lights, such as when I plug in the USB or unplug it. It doesn't make any clicking or unusual sounds as another ext. drive I had that died recently.