Lacie Usb Drive Not Mounting


I have purchased a LaCie 80gb mobile hard drive with USB 2.0.

When I attached it to a Windows XP machine and to a Mac Mini, it mounts fine. When I attach it to a new Powerbook 1.5ghz, it will not mount. the drive is detected in the system profiler, but not in Disk Utility. I am running Tiger 10.4.2. i have already tried to reset the bus by removing the battery for 15 minutes and as per advice in other threads.

Any thoughts would be welcome.




I'm having the same problem and I see that many others are too, but there aren't any answers posted. Please share if you've found a solution! Thanks!


I found out that the 15" Powerbook has a low supply of power via the USB port. This is apparently a known problem and it can't be changed. The only way around it is to use the second USB adaptor that should have been supplied with your drive and attach it to the second USB port on your Powerbook. This will allow the drive to operate, although it does look a little inelegant.



Hi There, I'm Chris I work for a data recovery company in the UK. The problem you are having is likely to be one of 2 things:

File system corruption (hence the inability for the system to find the B-Tree)

Bad Sectors on the hard drive (quite common on the Western Digital or Maxtor hard disk that is likely inside your Lacie enclosure)

Your options:

Contact a data recovery company

Purchase data recovery software

If the problem is bad sectors, money spent on most software solutions will be wasted, however if it is merely a software (file system) problem then software is the cheapest option. It is impossible to tell which exact problem you have without a hands on look, but good luck!!!


The original HD on my 15" G4 powerbook was clearly dying a few weeks ago (couldn't even boot from it), so I replaced it. The new one works fine, but I bought a usb2.0 enclosure to recover my most recent data (older stuff had been backed up on DVD-RW).
The disk will NOT mount. It doesn't show up in any utility I have (Norton DD, Disk Utility, system profiler, etc). However, I took it to work, and a more IT savvy collegue was able to mount it on his Linux machine. He pulled it all off, but of course one of the DVDs he burned has some error on it.
How do I get this thing mounted? I using the double USB adapters to get enough power, etc. The light goes on, it spins for a while, but no one is home.



hello all;

when you say your external drives will not mount - does the drive appear in disk utility for you in faint text, or does it just not appear at all?

i have a nexstar 250GB external HDD - just this morning its icon will not appear in finder or on desktop, but disk utility does detect it (but the partition submenu is faint - as in menu items that are not selectable. i can, though, select it & verify/repair)

it runs over firewire
(also has USB - which i HAVEN'T tried)

haven't tried anything really techie yet ; not being very mac tech-savvy
(tried basic restart; eject disc & switch on again; verify & repair in disk utility - which seemed to think the external drive was ok??)

any thoughts anyone?
is my data lost?

cheers - mb


It's not showing up ANYWHERE in any form - not in disk utility or anything. Only places it showed up was on a IT Collegue's Wintel machine with administrator rights (did NOT show up on my PC machine at work either), and his sysadmin LINUX machine. He was able to recover everything, but I want to try and recycle this drive.