Laserjet 1010 Not in the printer list

Murdock

Registered
Hi,

I have an iBook (running OS X Tiger) which is wirelessly connected to a home network via a wireless router. On this network I have a Windows PC to which a HP Laserjet 1010 is connected via USB. I would like to be able to share this printer on the Windows PC so that I can print from the iBook.

I have set file and print sharing options on the Windows PC. I have then added a new printer in OS X over 'Windows Printing'. OS X sees the printer and allows me to add it after puting in a username and password (I used the 'Guest' username). However when I try and print from the iBook the printer initialises and then procedes to print "%!PS-Adobe-3.0 %RBINumCopies: 1 %%..." and then lots of random letters. I thought that this looked like the iBook wasn't using the right drivers and after checking it appears it is using Generic Printer drivers.

I have the install disk that came with the printer and have installed the Mac OS X printer drivers which are on there, however when I try to change the drivers that the shared printer is using, the Laserjet 1010 is not in the list that OS X generates.

I'm relativly new to OS X, however if I was using Windows when this happens I would normaly select the 'other printer' option and then point Windows to where the .dll files for the printer drivers are held, however I'm not sure if I can do this with OS X and I have no idea where the files would be if I could.

I'm a little lost, if you can understand the ramblings I've just typed could anyone please help me or even just give some suggestions as to what I could do as I've played around with settings for about an hour now and i've got no further (I think it's made me a little dizzy also)

:) Thanks in advance,
Murdock
 

gsahli

Guest
Here's your problem - HP doesn't provide CUPS drivers for its non-postscript printers. But CUPS drivers are required for Windows Printing/network printing.
Install the hpijs and ESP ghostscript driver set from:
http://www.linuxprinting.org/macosx/hpijs/

(And feel free to ask HP why they can't provide CUPS drivers - now that OS X and linux use CUPS!)
 

MisterMe

Registered
Ghostscript is built into Tiger. You are explicitly instructed not to install it unless your OS is older than MacOS X 10.3.
 

gsahli

Guest
MisterMe said:
Ghostscript is built into Tiger. You are explicitly instructed not to install it unless your OS is older than MacOS X 10.3.
Those instructions are specific to Gimp-Print. Tiger and Panther include a pared-down version of ghostscript - for Gimp-Print. All the other linuxprinting.org drivers require the full version of ESP ghostscript. You are welcome to try using hpijs without ESP ghostscript - I have.

Best Wishes.
 

catterpillar

Registered
That worked great, thanks guys! Woulda never done it without ya :p

Thanks :)
Murdock
Hey u seem to have successfully configured your Mac to your HP Laserjet 1010.. I have a similar problem and I'm hoping you can help me.

My HP Laserjet 1010 is currently connected via USB to a desktop computer operating on Windows XP. This is also connected to a wireless network through which several Windows laptops have no problem printing. However, I can't print anything using my Macbook (Mac OS X version 10.4.11) through the wireless network. I am certain that my Macbook is connected to the network because I can access the internet and files from other computers on the network. My Macbook can detect the HP Laserjet 1010 but when i try to print, it says "Connection failed with error NT_STATUS_UNSUCCESSFUL" and eventually.. "Unable to connect to SAMBA host, will retry in 60seconds...ERROR: Connection failed with error". I've also downloaded the Bonjour program on the desktop and programs HPIJS, Footmatic and Ghostwriter (i needed to download the ghostwriter because the HPIJS wouldn't run otherwise) on my Macbook as recommended in some online forums but I'm still having the same problems. HELP!
 

gsahli

Guest
caterpillar - should have started a new thread.
NT_STATUS errors are Samba errors, and are independent of driver issues.
There are many possible causes - Have you set your Mac to be in the same Workgroup as the Windows "server?" Do you have an account on the PC that you can use to login for file sharing already? What OS X version are you using - there are Samba problems on Leopard that aren't fixed yet.
Have you tried the Advanced Windows Printing using Samba setup, so you can enter
smb://[IP address of PC]/printer share name
(hint for Tiger:)
http://www.macosxhints.com/article.php?story=20070916131935539&query=Windows+printing+Samba
Guides for Tiger:
http://www.ifelix.co.uk/tech/3015.html
(for Leopard:)
http://www.macosxhints.com/article.php?story=20071026060126378
 
Top