Latest 10.1 update causes problems for OmniWeb

BraveHart

Registered
My daughter and I have both 10.1 running and we're using OmniWeb 4.0.5 without problems. Now after updating with the Software Update utility to the latest security Updates, OmniWeb now exits with this error every time.
"Unable to connect to the requested process: Cannot get task pid 1336144"

Anyone else seen this ?
 

Attachments

~vert

It's short for vertigo...
I haven't seen the error, but I would recommend that you both upgrade to at least version 4.0.6. It fixes some things that were introduced in 10.1.

The latest "sneaky peek" version 4.1sp4 is nice, although it crashes and has a huge memory leak. Kinda wild to come back to my computer in the morning and see that OmniWeb is using 865MB of memory (that's not a typo). Quiting the app and restarting fixes everything and the virtual memory in OS X keeps it from being an issue anyway. Freaked me out the first time I saw it, though.
 

BraveHart

Registered
Didn't know there was a 4.0.6 version available. Can not find it anywhere...
Does it exist ?
 

~vert

It's short for vertigo...
Originally posted by BraveHart
Didn't know there was a 4.0.6 version available. Can not find it anywhere...
Does it exist ?
Sorry about that..., it seems it is only on the FTP page. Go here and use the login: sneakypeek and the password: ireadthereadme.
 

BraveHart

Registered
Thanks.!
I tried 4.0.6sp1, but that gave the same error. 4.1sp4 however, works fine with no trace of the previously reported error.
Still think it's a compatibility problem between OmniWeb and the security updates to 10.1
 

~vert

It's short for vertigo...
Did you by any chance also install the firmware update? I only ask because I performed both security updates (10.1 and IE), but not the firmware, and I have seen no problems at all.

You might also want to reboot while holding down the Command + S keys until you see text, and after the text scrolls by, type in fsck -y. If it says it modified anything, type it in again. Keep doing that until it says that everything appears OK. Then type reboot. It might solve some unseen issues.
 

BraveHart

Registered
I did perform the latest Firmware upgrade before I installed the security update. I also re-installed 10.1 on a newly initiallized partition. fsck -y didn't report any errors, disk OK. I'm running out of options, but you may be right in that it could be the Firmware upgrade....:(
 

~vert

It's short for vertigo...
I generally always wait at least a week before perfoming the firmware upgrades. Let other people find out the problems before potentially irreversible damage is done. Just think of the errors introduced in the last several updates: Loss of ability to use 3rd party processor upgrades; loss of memory that was 'out of spec'; etc.

Let those who can manage to disrupt their system test it for the rest of us. You live on the edge, you can get burned ;)
 

blb

`'
FYI, I'm running the latest firmware (4.2.8) and the security updates, and am having no problems with 4.0.5 (using it to post this, in fact); G4/500 DP.

Is there any other useful information in /var/tmp/console.log or /var/log/system.log when you try to run OmniWeb? If you aren't big on Terminal, use the Console app (in Applications/Utilities) to view these files.

Originally posted by ~vert
Let those who can manage to disrupt their system test it for the rest of us. You live on the edge, you can get burned ;)
Your welcome...although I must admit, haven't had any problems yet...maybe I should stop before my luck runs out.
 

BraveHart

Registered
The console.log says:
"Starting '/Users/arneguld/Documents/OmniWeb.app/Contents/Resources/OmniGroupCrashCatcher.app/Contents/MacOS/OmniGroupCrashCatcher' for pid 439. task_for_pid (os/kern) failure"

I get the same on my G4 450 DP and a slot loading iMac.
The only difference to before is that when I re-installed 10.1 this time I didn't install OS9.2.1 and I didn't install the dev tools for 10.1. I'm running 9.2.1 on a separate partition.
 
Top