Lexmark B/w Laser Preinrer Optra Lxi Does Not Work With Tiger

Mac Framlingham

I have a Optra LXi laser printer connected to a G5 by Ethernet. It worked fine with Panther but although it can be addressed for printing in Tiger all its prints from WORD PREVIEW PAGES EXCEL is:

ERROR; undefined


The printer works fine from my G4 portable running panther.

The drivers on the Lexmark site are for earlier versions of MACOS

As anyone any idea what is wrong?

or on the Lexmark site "load file to printer" application is for?
That error means that postscript is arriving at the printer - but I don't think this is a postscript printer (Am I right?). The driver for this printer isn't included in Tiger; you'll need to install(or reinstall) it. I suggest you go to the /Library/Printers folder and delete the Lexmark folder (unless you have any other Lexmark printers - then you'll need to try uninstall instead), then install the driver.

Good luck.

PS - did it work via network before? Non-postscript drivers often don't support network printing.
The Optra Lxi is a postscript level 2 emulation printer and it still works under Panther via ethernet from my g4 portable. The URL you supplied leads to the page for Panther compatability. However I deleted the Lexmark folder as you suggested and downloaded the "OptraLx_10.4.dmg: PostScript printing solution for Mac OS X v.10.4" from Lexmark, but still no change.

Thanks for your help

Thanks for straightening me out on it having postscript.
Try the "generic" printer model in ADD Printer. That's a different postscript PPD.
Are you using IP printer > LPR? Tiger sometimes autodetects the queue/port correctly, sometimes not. Find the printer's queue name and enter that in the ADD printer dialog. If the printer supports IP > HP Jetdirect, use that instead (Doesn't need a queue name).

I set it up using the Generic Postscript Printer and it prints!!!! That's the good news. The bad news I have lost the duplex function; it is is greyed out.

Thanks for your help.
That's puzzling - makes me think there's just a typo in the Lexmark PPD. Or a corrupted file in whatever the installer installs...