Linksys BEFSR81 to Adit 600 T1 device??? Crazy.


OK, I'm setting up a fractional 768 kbps T1 connection to a small LAN. I had a Linksys BEFSR81 "Cable / DSL Router with 8 port switch" v2 laying around at home, so I figure I'd just use that to hook up my LAN to the T1 device, the Adit 600.

The Adit 600 has a single ethernet port coming out of the front, and I can plug either a crossover cable or a patch cable from this port to a workstation directly, set the workstation for DHCP, and boom, I'm on the internet. The Adit 600 is a router.

Furthermore, I can plug the same crossover or patch cable into any of the standard 8 Linksys ports, turn off the DHCP server on the Linksys, and keep the workstations set to DHCP. So the Adit 600 is still the router and the Linksys is functionally just a switch/hub.

But, I want the Linksys to function as the router, and the Adit 600 to function as an internet source ONLY. Normally, this is done by connecting a cat5 cable from the Adit 600 to the WAN port on the Linksys router, but whenever that is done, the Adit 600 diagnostic lights go red and the WAN ports on the Linksys are dead.

I have tried configuring the WAN port on the Linksys per my ISP's specifications, but to no avail.

This is where it gets crazy:
I chatted with Linksys tech support online (nice, by the way) and after describing the above details, they said I had a 50/50 chance of getting the WAN port to work directly plugged into a T1 device. WHAT???
They also recommended that I use a Linksys BEFCMU10 Cable Modem as a "signal converter" between the Linksys router and the Adit 600.

They were unable to say exactly why, but I just want it to work.

Can somebody shed some light on this strange suggestion?
Furthermore, I have the suggested cable modem at home (BEFCMU10), and I'm beginning to think that Linksys rep is full of crap. It's only got one ethernet port. Also a coax cable connector and a power connector.
Problem solved! Or at least identified. The WAN port on my BEFSR81 is malfunctioning somehow. Plugging a workstation into it produces blinking lights, which supposedly shows it is working, but I brought it home and tested it out on my cable connection at home, and no go there either. So I brought my wireless router / gateway (WRT54G) and tried that out on the T1 box. AND IT WORKED FLAWLESSLY. :)