Linux... again...

SAbsar

Mac Graduate
A while ago, I tried installing YDL 2 on my G3 Wallstreet. Didn't work, so I gave up, and my Wallstreet's been eating dust since. Now I wanna put it to _some_ sorta use! I just want to get _any_ flavor of linux working on the book!

Could anyone please suggest a distro, and provide a step-by-step installation guide for me? I'm a total linux newbie, and I've got Mac OS 8.1 on the wallstreet.

Thanks in advance!
 

nixgeek

Mac of the SubGenius! :-)
Well, you can try Fedora Core 4 which finally has a PowerPC version. You can also try Ubuntu or Kubuntu (KDE version of Ubuntu), Gentoo, Debian, SuSE, etc.

Remember that the Wallstreet models are Old World Macs, meaning that they won't boot from a Linux CD like a New World Mac would. New World Macs use OpenFirmware and don't require a Mac OS installation. They can also boot from Linux CDs when you hold down the "C" key.

With Old World Macs, you are still using a hardware ROM which requires that a Mac OS be installed in some partition. However, if you create a small partition just for the Mac OS to hold the kernel and use BootX, you can use BootX to do the installation and then to boot into the Linux partition after the install.

Check the following site for more information on BootX.
http://penguinppc.org/bootloaders/bootx/
 

SAbsar

Mac Graduate
Wow, nixgeek! That was the most helpful help ever! Really! But there still remains one little problem. None of the linux distros I have will install.
FC4 quit on me JUST before it began copying files, giving me an error something about memory allocation. Mandriva, YDL 2 and YDL 3 quitbefore the installer even fired up! Abnormal termination, rebooting in 180 secs.... what is that about?
 

nixgeek

Mac of the SubGenius! :-)
When you started the install, did you do it from the Mac OS desktop with all extensions loaded? If so, then that might be the problem. Whenever I tried to kick Linuxinto gear with tthe Mac OS fully loaded the Linux boot process hanged on me.

BootX comes with an extensions that loads before any of the extensions and control panels come up. Drop that extension in the System Folder and reboot. Onec rebooted, you'll see that Welcome screen. Right before it starts to load the extensions, the BootX extension kicks in. Select Linux (with all of the parameters for an install) and you should be good to go.

As to why this happens, I'm not sure. But it does. :rolleyes:
 

SAbsar

Mac Graduate
Lol! It's like BootX just doesn't wanna play :) After I copied the extension into the correct folder, i get this message at startup: "Could not load a suitable kernel file" :(
 

nixgeek

Mac of the SubGenius! :-)
OK, in the BootX folder there's another folder called Linux Kernels. That needs to be in the System Folder also. BootX looks in the System Folder for this folder with the necessary kernels. You'll have to copy one of the kernels from the Linux CD into that Linux Kernels folder. It's usually in a folder called install in the CD and you'll see the "vmlinux" images. Make sure you get the one for powerpc as there might be other for POWER and other PowerPC processors that aren't for the Mac.
 

fryke

Moderator
Staff member
Mod
(Doesn't the Wallstreet still make quite a decent OS 8/9 computer? I mean: I can understand the need to tinker, but I'd make such a notebook the project of finding the best version of classic Mac OS and give it the applications that make it the good notebook it was in its days...)
 

nixgeek

Mac of the SubGenius! :-)
fryke said:
(Doesn't the Wallstreet still make quite a decent OS 8/9 computer? I mean: I can understand the need to tinker, but I'd make such a notebook the project of finding the best version of classic Mac OS and give it the applications that make it the good notebook it was in its days...)
I tried that on my StarMax 4000. The fact that i'm relegated to using IE and proprietary IM clients is one of the reasons I don't use it on Mac OS 9 so much. About the only thing I'm using it for now is to run Master Tracks Pro for my sequencing....nothing else.

I'm usually booted into Debian Sarge on that same StarMax. It runs quite well, even with only 128 MB or RAM (though not exactly a speed demon either). Under Debian I can use Gaim for IM, Firefox for web browsing, and various other up-to-date apps that I'm used to. Plus, I'm running a Unix-like operating system with is the closest I'll ever get to Mac OS X on that computer.

Since this is a Wallstreet PB, it would run even better since it has a G3 (my StarMax has a 604e CPU) and an ATI chipset (which is better supported under PPC Linux). I attempted this with a Wallstreet II laptop but for some reason I couldn't even get farther than SAbsar did. For all I know it was due to my lack of knowledge at the time.
 

SAbsar

Mac Graduate
Yes, fryke, that IS a tempting use of the Wallstreet, but as nixgeek pointed out, I just want to use up-to-date software :)

Well, nixgeek, I tried that, but it still won't budge! Yellow dog installer won't fire up, FC4's will, but just as it's about to start copying files, it says "could not allocate memory" :( Mandriva is still giving me that Rebooting in 180 secs message. With mandriva, I'm using the vmlinux-power4 kernel and associated ramdisk image.
 

Viro

Registered
SAbsar said:
With mandriva, I'm using the vmlinux-power4 kernel and associated ramdisk image.
Now, this could be an issue. Macs use the PowerPC architecture, which although is similar in many respects to the POWER architecture, there are subtle differences. This could be why you are having problems running. Try booting with a powerpc kernel instead and see what kinda results you get.
 

nixgeek

Mac of the SubGenius! :-)
And btw, the power4 kernel is for the G5. You need to use the powerpc one.

EDIT: Blegh...took too long to answer...thanks Viro! :p
 

SAbsar

Mac Graduate
Hi. There was no powerpc kernel. there was a 601 kernel, a power4 kernel, and this other one labelled all. The 'all' version didn't work. Lemme focus on the FC4 thing now. in a folder lablelled 'ppc', I've got 4 folders: 'chrp', 'iSeries', 'mac', 'mac64'

Each of these contains a kernel file, and a ramdisk.image.gz file. Which do I use? I'm currently using the one inside 'mac'

Now for the Mandriva disk. Inside a folder labelled 'boot', I have 'vmlinux', 'vmlinux-power4', 'vmlinux-ppc601', and three other files: 'all-power4.gz', 'all-ppc601.gz' and 'all.gz'. Which do I use?

Help me out, coz I really dont wanna quit on the whole linux-on-my-book thing!
 

nixgeek

Mac of the SubGenius! :-)
Well, think about it. Your PowerBook has a G3. It can't be a mac64 since it's not a 64-bit processor (PowerPC 970, aka G5). It also can't be power4 because that's for the POWER processors. As for the ppc601 kernel, that's for Nubus-based Power Macs (pre-PCI). The chrp image is for non-Apple PPC machines that use the Common Hardware Reference Platform design. The iSeries is for the IBM iSeries servers.

So it would either be "mac" or "all" (since the latter would encompass all the processors including the G3 even though that didn't seem to work for you).

Why don't you give Debian a try? It's what I'm using in my StarMax and has worked for me more than any of the others. That one does have a powerpc kernel image that I know will work with the G3. Heck, mine has an older processor than your so it should work on your PowerBook.
 

nixgeek

Mac of the SubGenius! :-)
BTW, the latest Debian Linux ("sarge") is much easier to install. I would recommend downloading the net-install ISO image since it would basically install a base system and install any other applications over the Internet.

Also give Ubuntu a try since it's more Debian based and we know that it works. I've installed it on a Power Mac G3 blue and white (both Debian and Ubuntu that is) and it's worked fine.
 

SAbsar

Mac Graduate
Oh! So, I've been doing it all wrong then! :p

Okay, I'll start dowloading Debian. Considering I have dial-up, expect it any minute now! :D
Thanks for the wonderful help! I'll update when I'm done!
 

nixgeek

Mac of the SubGenius! :-)
LOL....you didn't mention you had dialup. Good luck. :D

Actually, you can order the Ubuntu/Kubuntu CDs and they will send it via snail-mail for free. The only thing you might have to pay for is shipping if anything.
 

kickassmac

Registered
ubuntu power pc has a very straight forward installation and an intuitive GUI, however i dont know if your mac is supported, and i had to fiddle around with mine to get the sound to work. theres also a live cd which can be useful for just looking.

http://se.releases.ubuntu.com/5.04/

i think gentoo do a power pc version aswell, though havent tried it.


PowerBook G4
 
Top