Locked file - how to delete


I have a big problem with my MacOS X release (10.0.1).
My Trash is filling with data I can't delete! I tried everything, logging in as root, everything. I even tried deleting them
manually with rm in the terminal. It always says the action is permitted.
Can anybody help me? Is there a way to delete them in MacOS 9.1? Can I find the Trash there somewhere?

please help, thanx!

boot on os 9.1
do a sherlock search for "trash" on your os x volume
open the folders
if it tells you it cant open an item inside an invisible folder, make it and/or its containing folder(s) visible by using apple's resedit get info command.
I have also just experienced the same problem for the first time. Surely there must be an easier way around it...?
I've been looking for a workaround (these ya-newswatcher help files got me mad) but i guess if the root user cant delete it, the security features of an unix completely prevents you from deleting it when booted normally. You could probably boot in single user (hold command and s at startup) and delete them from the command line (rm file). But when it comes to many files, I think it’s faster to do it in OS 9.