login crash on one account only


Here's a strange one: I have two accounts in Tiger (10.4.1); the one I use 90% of the time has become inaccessible. About 20 seconds after I log in to that account the desktop disappears (amidst heavy disk activity), and I find myself logged off that account and back to the login screen. Can't get back in at all. Fortunately the other account (both are admin accounts) still works normally although the same thing happed there, but just once. I've checked disks from OS9 (all OK) repaired permissions, even reinstalled the 10.4.1 update hoping some corrupted file would be replaced.

I had been using Tiger since release without problems. This problem first happened around the time I noticed that Virex mysteriously disappeared (later learned Apple dropped it as a .Mac supported service -- can I expect a partial refund? Ha!). I hastily downloaded Virex 7.5 (not noticing at first that it is for Panther only -- Huh??) In verbose mode I noticed numerous error messages during startup complaining about not being able to load "com.NAI.SysCallExt." So I deleted VIrex and any remnants I could find, including Virex.kext. Still no good. I'm not sure this has anything to do with the problem anyway.

Anyone have any suggestions, short of a reinstall? Thanks.
Since posting I was able to find the login crash report. I doesn't help me but perhaps it is a good clue for someone who understands these things! Here is the first part of the log:

Host Name: MainMac
Date/Time: 2005-06-26 21:58:37.732 -0400
OS Version: 10.4.1 (Build 8B15)
Report Version: 3

Command: dmnotifyd
Path: /System/Library/PrivateFrameworks/DMNotification.framework/Resources/dmnotifyd
Parent: launchd [1]

Version: ??? (???)

PID: 231
Thread: 0

Exception: EXC_BAD_ACCESS (0x0001)
Codes: KERN_PROTECTION_FAILURE (0x0002) at 0x00000006
Rin 'fsck' and see what errors you get;

To run fsck, you first need to start up your Mac in single-user mode. Here's how:

1. Restart your Mac.

2. Immediately press and hold the Command and "S" keys.

You'll see a bunch of text begin scrolling on your screen. In a few more seconds, you'll see the Unix command line prompt (#).

You're now in single-user mode.

Now that you're at the # prompt, here's how to run fsck:

1. Type: "fsck -f" (that's fsck-space-minus-f).

2. Press Return.

The fsck utility will blast some text onto your screen. If there's damage to your disk, you'll see a message that says:


If you see this message--and this is extremely important-- repeat running fsck. It is normal to have to run fsck more than once -- the first run's repairs often uncover additional problems..

When fsck finally reports that no problems were found, and the # prompt reappears:

3. Type: "reboot" to restart,

or type "exit" to start up without rebooting.

4. Press Return.

Your Mac should proceed to start up normally to the login window or the Finder.

Thanks for your reply. I tried fsck in single user mode and it reports that the disk is normal. I think the problem has something to do with permissions in the user account having the problems -- but I don't know how to check them because they are not on the system partition. I keep the user account folders on a differrent partition from the system -- necessary because this is on an old G3 Beige (with G4 processor and other updgrades) which limits the system partition to 8 gig. I installed Tiger with Xpostfacto. Anyway, from Disk Utility I can verify and repair the partition with the offending account (reports as OK and always did) but can't check permissions. (Or do permissions only apply to the system partition?)

Any other suggestions would be appreciated. Its a bit of a trick to get this machine to think any DVD drive is bootable, so reinstalling Tiger is a pain I'd like to avoid.

Thanks again.

Cliff Sinnott

P.S. I've tried the Tiger version of OnyX (1.6b2) to repair permissions, but if I'm reading the log correctly, its not able to access the files in the bad account.
Open Terminal and type this to see what the name of that partition is;

diskutil list

Then type this to repair permissions on that partition;

diskutil repairPermissions disk0s3

(Changing 'disk0s3' to the name of your partition.)

Tried what you said, even logging in as root first, but still get this result:

MainMac:~ root# diskutil repairPermissions disk0s10
Error (-9998) "Invalid request" encountered attempting to verify/repair permissions disk0s10 Users
MainMac:~ root#

In DIsk Utility the options to verify or repair permissions are alway greyed out unless the system partition is selected. Is that normal?

Thanks again for your help

Yes, that's normal.

Startup holding the Shift key down and see if it boots fully without crashing.