login window fails

shankell

Registered
I'm running both OSX and OS 9.1 on my Powerbook G3 Series (Bronze). Today I upgraded to 10.0.1, and now it won't start up:

I was logged in as admin, then I logged out and logged in again as root. I changed the priviledges on Macintosh HD (essentially gave Root and admin full R/W access, and all others no access except for one folder. I then logged out, but it wouldn't let me log in again... Like no login screen or anything. I tried force quitting, and force rebooting, but nothing, so I hit the little button on the back to reboot. The smiling computer came up and went by, but then it stopped and got stuck on a blue screen that flashed every 15 seconds or so.

I ran Disk Utility, but it said the disk as fine, and when I rebooted again, there was no change. I started up in verbose mode (cmd-v) and after all the text was through, I was back to the flashing blue screen but this time there would be 15 seconds of blue followed by a quarter second or so of a message about the loginwindow failing.

Now I can boot into single user mode (text only), but I still can't login to Mac OS X multi-user mode.

Any tips?
 

VGZ

Registered
When you changed all the permissions you broke several things. I did what you did on the PB and had to format and reinstall to recover because none of the apps would work due to incorrect permissions. You should reboot into 9 and backup any important items. You might want to call Apple for support but you might be forced to format and reinstall.

Sorry to be the bearer of bad news :(,
 

Elder Dan

Registered
If you fiddle with permissions of anything under /System, or in any of the hidden / directories (/Volumes, /private, etc.) you pretty much are playing russian roulette with your machine... :)
 
Top