lost access to my system preferences

#1
I cannot bring up my system preferences under the blue apple icon or through a search.
I installed and ran MacJanitor v 1.3 a month or so ago and perhaps that's the cause? I have been missing my Mail prefs for a long time so switched to Thunderbird but I don't know if the two incidents are related.
iMac G5,1.6 GHz, 1.5 GB, OS 10.3.9
 
#3
For my system prefs, when I click on the blue apple and then on System prefs, absolutely nothing happens. As if I didn't do it! And I can't locate them in a search.
For Mail, when i click on Prefs, all I get is the Rules window. Nothing else.This happened before I downloaded MacJanitor v 1.3 and ran it. I don't know when I lost my System Prefs.
I guess I can reinstall the OS but that's a pain if I don't have to.
Any ideas?
Thanks
 
#4
Wow that is very odd. Never heard of that before, are there any other accounts to use? I would see if you can access prefs from another account. Have you tried to repair the disk using Disk Utility from the install DVD?
 
#5
No, I m the only user of this computer and in any case, I can't access my account because I can't access the system prefs!
I used Disk Utility on the hard drive to check and repair permissions but that didn't help.
I didn't try it from the Install CD. Would that make a difference?

Also when I click on the apple, thenLocation> Network Prefs, nothing happens. Do you think Mac Janitor could have caused this?
Thanks for any help you can give me!
 

Giaguara

Chmod 760
Staff member
Mod
#6
Do you have any third party system preference panes installed?
Or APE? If you have APE, uninstall it.

Get rid of the file ~/Library/Preferences/com.apple.systempreferences.plist
(where ~ is your home folder)
and if still occurring, delete the folder (if present) ~/Library/Caches/System Preferences
then log out and back in. Still happening?
 
#7
Hi Giaguara, no I don't have any third party system preference panes installed.
I just followed your advice but nothing has changed. And the computer didn't create a new file to replace the one i trashed. i still have it in the trash.

My only option for internet here is dial-up and they just changed the access number. If I can't get to my prefs (Network prefs are gone too) to change the number, I won't be able to get online!
 
#8
That does present issues. I think it is possible that you may need to perform a reinstall of OS X. I'm not sure how the system got into such a state. You've tried scanning the disk from the DVD using Disk Utility is that correct?
 
#9
First of all i used Disk utility on my hard drive. it repaired some permissions but still no prefs. So tonight i used the DVD to verify and repair and it did it over again but still no results.
I don't know how the REstore option works so haven't used that.
I haven't gone to Apple because it takes me hours to navigate through there on dial-up- to see if they have any answers.
I really appreciate your suggestions, thanks.
 

Giaguara

Chmod 760
Staff member
Mod
#10
Hm...
Let's try creating a new user to see if your problem would persist there too

Boot to single user mode (cmd-s at boot), there type

mount -uw /
rm /var/db/.AppleSetupDone
enter after each line, and note that there is only one space in the second line and that is just after rm. So /var/db/.AppleSetupDone doesn't have any spaces in it.

after which you can get it to

It should launch the setup assistant for creating a new admin user (while keeping your current user safe and sound). That new user needs to have a different shortname as your current user.
Two possibilities when you are logged in as the new user: either the problem exists there too, or you can get to system preferences, either of which will give more clues on the next appropriate step.
 
Last edited:
#12
OOps! Now I'm stuck. I'M USING MY LAPTOP....right after "localhost:/root#" i hit enter to move it to the next line but it repeated localhost etc. so I typed in what you said right after the cursor. Nothing happened after I typed "reboot" so I read back and it says-
mon May 17 etc
Singleuser boot-- fsck not done
Root device is mounted read-only
if you want to make modifications to files,
run'/sbin/fsck-y' first and then '/sbin/mount -uw /'
localhost:/ root#

the fan is running like crazy so I'm going to use the on button to shut it down. OK, that worked- now to restart normally....whew! I didn't wreck anything.

This is scary stuff for me- but now you have a bit more info about the HD. Perhaps I should just reinstall the OS. I'm going away for 2 weeks tomorrow so can't follow up until I get back June 2nd. I will have my laptop so can read your reply but won't be able to do anything. I sure appreciate your interest and help! Thanks!
 
#14
Actually, I think it was there all along, I just didn't read 6 lines back. I was figuring out where to start typing.
I bought this computer used and I worked with MacOSX techies to change the name from the former owner to me. That involved work at the root level. Perhaps that has something to do with the read only??? That was 2 or 3 years ago so has nothing to do with the preferences disappearing now.
There was no error message- it was just part of all the typing on the page.
 
Last edited:

Giaguara

Chmod 760
Staff member
Mod
#15
That would probably have to do with it.
I wish it was made more difficult to change the username or home folder name as that usually causes too much accidental problems...

(This part is kind of late for now, but can be useful for later reference)
If you would NOW have that Mac in front of you as a just purchased one, before setting anything in it, I'd recommend first a clean install of the OS. Just for starting as a clean table.
(Or, if/when eventually selling yours, install Mac OS X from discs. When after reboot it starts with user setup assistant, you can power the computer down. It will proceed from that point when the new owner powers it on)
If it's got a clean system, but an account with a name you don't like, there are a few ways to change the username. But if nothing is set up ever for that dummy account, in that case you might as well create yourself a completely new admin account, log out of the old one and in as the new one and then simply delete the old one.

And back to the single user mode, after you did the /sbin/mount -uw / and then the lines earlier for getting the setup assistant to launch, were you able to get the new user created, and if so were the system preferences working successfully as that user?

(and when you'll see that line of localhost:/ root# that is where you can start typing)
 
#16
Yes, I did that change about 2 years ago and the preferences worked until just recently. I have created other user accounts that were complete too, but they weren't admin accounts.
Really, i wonder if macJanitor took the prefs out????
 
#18
Hey, just a note... I was watching TekZilla and they mentioned something called Apple Jack to fix OSX. One of the things it can do is validate preference files. Don't know if it would help but, try it, can't hurt right?
 
#19
Hi Titan Shadow and Giaguara,
Thanks so much for your continuing help! Right now i am on holiday and have my laptop but my iMac is at home so I can't do anything until I get back. when I created temporary non admin users they could access their own system prefs but not mine.
I'll look up apple jack to see what it says.
Thanks again!
 
#20
Hi, I'm back form holiday and looked at Applejack as you suggested but was afraid to try it as there are too many unknowns for me.
I have been checking these forums and found an answer!

I didn't know the system prefs are an application so I followed the advice to find them under Applications and open them there. It worked so I created an alias for the dock and that's good enough!it works!

Thank you all for your help and interest!
 
Last edited:
Top