Lost Directories/files When Navigating Through Shell

cakkafracle

Registered
Today, for some reason, my second hard drive lost track of it's directories and files.

I noticed this because all my symbolic links were broken. I searched through the finder and I see all the files are still there, but when I look through the bash terminal, I can't find most of the drive.

I've tried rebuild the file DB using 'updatedb' but that didn't change anything. Does the Finder use a different method of tracking files/directories than bach?

Are there are methods of rebuilding the drive's directory?

UPDATE

Ok, here's what I found
Upon looking closer in my terminal, I saw that my /Volume/Primus folder was COPIED as /Volume/Primus 1/ and a new folder called /Volumes/Primus/ had been created about 8 hours prior (the night before).

I renamed the /Primus 1/ folder back to /Primus/ and everything worked again. I just made sure anything new in the incorrect folder was transferred.

SO, my question here is... HOW could a Volume directory get copied like that? Where does /Volumes/ actually reside, on the boot partition?

I've never seen this happen before, and I'd like to avoid it.
 
Top