Lost Ip Address Powerbook With Orinoco Card


i am running os10.2 on my wallstreet powerbook with a sonnet g4 upgrade and a orinoco pc card using the sourceforge wireless driver beta_5. everything was working fine for a while but lately, whenever i boot into 10.2 from 9.2.2, my computer joins my specific "closed" airport base station (graphite) network ok but self assigns a new ip address that won't let me connect to the internet. the self assigned ip address is 169.254.249.xxx. if i go to tcp/ip "manual" and type in a 10.0.1.x ip address and my airport base station router address it still doesn't work. if i reboot into 9 and reconfigure my airport base station network to "open" using the airport admin utility and then reboot into 10 the dhcp server assigns the correct ip address (10.0.1.x) and i can connect to the net. i tried reinstalling the sourceforge driver without luck. i don't understand os10 well enough to know where to make adjustments. i don't understand how i can be connected to my specific airport base station network with a strong signal and not get the proper ip address assigned.

i searched the archives and found a short string in march 2002 "lost tcp/ip number after wakeup" that is almost identical to my problem. nobody joined the string with an answer.

another symptom i noticed is that when the problem first showed up it started taking (and continues to take) much longer than usual for my startup sequence in os10 to get through the "waiting for network initialization" step.

i don't recall having installed any new software or having made any other changes to my system just prior to the problem showing up.

i have two other computers on my airport base station network, one running 9.2.2 and one 10.2 and they both work fine.

thanks for being here, jschwell