Lynx And _nl_langinfo


I maintain a web site, and would like to preview in as many browsers as possible. I am on OSX 10.2.8. I downloaded Lynx (from When I tried to run the result, I initially had a problem because it couldn't find lynx.cfg where it wanted it. I managed to get around that, but here is a complete transcript of the result.

Last login: Thu Aug 4 09:36:53 on ttyp1
/Applications/Lynx/lynx.command; exit
Welcome to Darwin!
[your-vp7x3s9ctm:~] dad2% /Applications/Lynx/lynx.command; exit
dyld: /Applications/Lynx/lynx.command Undefined symbols:
/Applications/Lynx/lynx.command undefined reference to _nl_langinfo expected to be defined in /usr/lib/libSystem.B.dylib
Trace/BPT trap
[Process completed]

Any ideas what I should do to fix this? Just for the record, I tried an earlier release of Lynx which needed to run from the terminal shell, and it failed because it was also missing several definitions from the same library,
With the 'Lynx-2.8.6' disk image on the 'Desktop' (as a result of double clicking on the 'Lynx-2.8.6-10.2-10.4.dmg' file), all you had to do was launch 'Terminal' and enter ...

sudo cp /Volumes/Lynx-2.8.6/lynx.cfg /usr/local/lib/lynx.cfg

... and press the <return> key. After entering the (optional) administrator's password and pressing the <return> key, 'lynx.cfg' would have been properly installed. Is this what you did?

Anyway, once the above is performed, double-clicking on 'lynx.command' produces a 'Terminal' window from which you can now surf the internet, via text.
The sudo isn't precisely what I did, but I did get lynx.cfg to the right place. Unfortunately, the problem is that _nl_langinfo, which is expected to be defined in /usr/lib/libSystem.B.dylib, cannot be found, so I'm stuck at that point. My guess is that I need a new version of that lib file, or some equivalent, in order to proceed, but I don't know where to find it..
I have an external hard drive (with multiple partitions, and thus - multiple MacOS X'es installed) with a 10.2.0 partition. I have viewed its '/usr/lib/' folder. It does contain 'libSystem.dylib' (an alias to 'libSystem.B.dylib') and 'libSystem.B.dylib'. I '.zip'ed the two files into a file titled ''.

Click here to download '' (the file will be deleted any time after 20 August 2005).
I appreciate your efforts in looking at this problem and getting me this file. Alas, it seems to lack _nl_langinfo as well. However, there is good news anyhow. Although the port of Lynx from the Mac site had this problem, downloading a different port with Fink Commander works correctly. So I guess I'll just classify this as a mysterious, and thankfully avoidable, problem.