mac os x 10.0.4 with sgi 1600sw, window manager wierdness

nabisco

Registered
Is anyone using a SGI 1600SW with OS X successfully? I've been having an issue with the screen going blank and the Window Manager process eating up 100% of the CPU ever since 10.0. I connect the 1600SW to my G4 using a Multilink Adapter to an ATI Radeon AGP card and have tried both Analog and Digital modes with the same results. It gets to the point where I can't even ssh to reboot the system (I might be lucky if I were to get a shell prompt in 5 minutes).

Here's my config:

G4 400 (Gigabit Ethernet)
512MB RAM
25GB Seagate Barracuda ATA-2
SGI 1600SW + SGI Multilink w/Belkin ADC-to-DVI converter
Mac OS X 10.0.4 w/Classic installed on same partition
Mac OS 9.1 on separate partition
 

nabisco

Registered
I forgot to mention that this setup works fine under 9.1 without any crashes or hangs.

Also, replacing the monitor with another (Sony CPD-4410) causes it to be stable; so, I'm sure it has something to do with the 1600SW. Clearing out the preferences for ColorSync appears to make it a little more stable (as does replacing the monitor, booting, shutting down, and putting the 1600SW back on); but, only for a day or two and then it's back to going nuts within 1 to 5 minutes of showing the login screen.

I've tried resetting the PMU and clearing any and all display preferences found in /Library, /System/Library, and ~/Library with limited success (sometimes it works and makes the system stable for a few days).
 

mbuss

Registered
I have almost the same configuration except I do not have the Belkin converter. Instead, I use the Multilink to plug into the VGA port, which works like a charm. Perhaps the converter is the problem.

One issue I do have: some games will automatically set the resolution to 640 x 480, which is not supported and results in a black screen. My workaround is to not play games, and that ain't no fun.
 

mbuss

Registered
Then there's something wrong with my setup. Every time I launch, say, Quake III, it switches to an illegal resolution and the screen goes black. When I hit Command-Q, everything returns to normal. As a VersionTracker devotee, I can assure you I'm completely up to date with my software updates, so I don't know how to proceed.

Maybe I should start opening some of the games' .plist files and jigger with the settings.... Do you have any suggestions?
 

nabisco

Registered
I think the problem might be related to not having the ADC to DVI converter. The SGI Multilink Adapter requires that the signal is passed in with a 60 Hz refresh when it's doing analog to digital conversion. A change in resolution may result in a change in refresh rate as well. In digital mode, that doesn't apply, which might fix your problem.
 

mbuss

Registered
That's all I need is ANOTHER box on my desk. A monitor to an adapter to a converter to a CPU...all I'm missing is a couple of tin cans and a string.

You're probably right, though. I think instead, I'll just boot into OS 9 if I really need to play games.
 

nabisco

Registered
The Belkin ADC to DVI converter is just a small cable that connects to the end of the DVI cable to convert it to ADC (it's about 4 inches long and barely noticeable since it sits on the back side of your Mac).

But, OS 9 is a good alternative and it was what I did for a long time when the system wouldn't stay up longer than 5 minutes at a time.
 
Top