Mac OS X 10.3.9 update failure!


Hi everyone,

I was trying to update my mac ibook G4 from mac os x 10.3.8 to 10.3.9 and i used the software update option, however halfway through the download i got a warning sign saying that it could not be completed. Then i tried to do it from the apple website using not the combo download but the other option only available for updates from 10.3.8 to 10.3.9. At the end of this download a warning sign came up saying that the disk could not be mounted. Then i decided to restart the computer thinking that maybe the first installation had been succesful. However, after the apple sign came on the screen and start up was running a message appears on the screen saying:

"You need to restart the computer. Hold down the Power button for several seconds or press the Restart button."

The message is in 5 other languages as well... I tried to follow those instructions but the same happens over and over...

Could anyone please advice me on how i can repair this issue?

Thanks a lot in advance,
Well, you did about everything wrong that you could - and I know that won't help you, so I'll try to now.

First: You created a backup of everything important, right? So you won't mind reinstalling Panther cleanly. If you haven't done that, well: Do so now. You can use an external FW drive to do that.

Reinstall Panther from the original disks that came with your computer. If you haven't made a backup (because you ain't got a FW drive maybe...) you can do so by choosing "Archive & Install" instead of Clean Install. That way, the old system gets archived and you end up with a clean installation.

Then, download the COMBO updater. Never get the smaller one, they're no good. (Well, they often _do_ work fine, but sometimes don't, so get the combo instead.)

After updating your clean system to 10.3.9, you can get your files and settings back from the backup.
Also: Try not to double-post (you've accidentally created this thread twice, had to delete one...) and use search before creating a new thread. There are a lot of threads about the problems of updating to 10.3.9... Maybe you'll even find a solution that fits you more...?
Thanks fryke for your quick response, so if i do and archive and installation does that mean that i can recover all my files? and third party applications? And about updating to 10.3.9 , can i do that right after a new installation?

Thanks again,
Hi again, as you can see i am not a literate mac user ,what do you exactly mean by an external fw? just any external usb? how can i transfer my files to this external fw?

Thanks a lot,
FW is an interface, like USB. You have Firewire or USB, it's like what Mac is to PC, two different components in the same field.

So, an external Firewire Hard Drive is simply an external hard drive that requires a firewire connection.
Still i havent been able to solve the issue, so far i tried to log on in safe mode, and got rejected, then i did single user and ran the fsck , and it reported a failure, when i tried to repair the disk by booting from the install disk and using the disk utility it also reported a failure on an exit. So then i tried the archive and install, but i only have 3.1 GB available on my ibook so appearantly that could not be done. Because after the installation it reported and error. I am wondering if it is possible to delete some files without doing it from the desktop. The problem is that i cant even get to my log in window so i dont have access to my hard disk. Then after recovering some of the data i could run an erase and install? I appreciate any help!

Theoretically you could get to a command line prompt, mount your file systems and do it "by hand". But you'll probably be better off getting a FireWire drive, install Mac OS X onto that instead of the internal, then recover the files you need to the external drive and completely reinstall on the internal. And: Never let the empty drive space become so low. While using Mac OS X, the system needs (lots of) disk space for virtual memory - and possibly it was full when trying to update to 10.3.9 for the first time...