Mac OS X root password

To use NetInfo you just have to open up the program ( it is in /Applications/Utilities/ ). Open it up, then under one of the menu's it says enable root user, just do that and change the password. I find that using the CLI is easiar though. Just open up a terminal and type in 'sudo /bin/tcsh' then 'passwd root' and enter the root password. If neither of those ways work let me know, I'm in classic right now (my dad doesn't like X because it is slow) but anyways i can just boot into X and find the correct way to do it.

I noticed that if I login as a non-administrator and I attempt to "sudo", I get a cautionary message and then the password prompt. If I then enter the *correct* root password, I always get a "wrong password" error. If I login as adminstrator, I can sudo successfully, and I get the password prompt right away.

I assume non-administrators should also be able to sudo, otherwise why give the password prompt?

Am I missing some netinfo-like subtlety?
No, that is what is supposed to happen. If you edit the /etc/sudoers file, then you can control which users can use the sudo command and which users cannot use it. If everyone could use sudo, that would mean everyone would have full control over your computer.
Thanks jpc.

However, It would be nicer to have a more understandable message, like

"You are not allowed to use 'sudo', please contact your administrator"

instead of claiming that the correct root password is wrong.

Needless to say, I'm the only one using this machine :)
The message should show:

"user not in /etc/sudoers file"

It shouldn't say anything about the root password being incorrect. Whenever I try to sudo without permission to in YDL 2.0 and in X, i get the message above.
A non-admin user who tries sudo with their own password will see:

username is not in the sudoers file.  This incident will be reported.

which results in an email being sent to root stating who and what...

Note that sudo uses the username's password, not root's password.
My mistake. I thought I had to give the *root* password for "sudo", instead of the password for the sudo-enabled user. That's why I got a wrong-password error.

Thanks for yout help!