Mac Osx 10.4.2, Laserjet 2300 "printer Busy"


I have recently upgraded to Mac OSX 10.4.2 Tiger.

I have a HP Laser Jet 2300 connected to my Mac via USB.

When I boot my Mac, I am able to print to the HP 2300 "One Time" successfully.

After that, every time I try to print it says "Printer Busy".

If I reboot the Mac again it repeats the same scenario.

I have checked, and all of the drivers are up to date.

I have delete and reinstalled the divers both manually and automatically, but nothing works.

Any suggestions?

Sincerely, Stuart Damon

Posted elsewhere...repeated here for possible clues it might bring........

I'm running OS X.4.2.

I have checked all Mac sw updates, connect to a wireless Netgear router, have repeatedly subtracted and added my 2200dn to my Printer List, have repeatedly reinstalled printer drivers, have done cold reset (I think) on the printer (which connects to the router by ethernet cable), have another portable Mac with the same printer configurations that prints just fine over wireless, and ... despite all that, I cannot clear the repeated "printer busy, try again in 10 seconds" message.

As you might imagine, this all once worked. For (lame) reasons, the settings for all the printers I connect to were wiped out, and I have been rebuilding them. Of course, the most important one to me isn't working.

New datum: it is possible to print with my main portable Mac over wireless to a different 2200dn.

Combined with being able to print to the problematic 2200dn machine with a different Mac, there might be some clue to narrow down the source of the trouble. [N.b., I had to add the second 2200dn to the printer list, just as the troublesome one.]
As Stuart Damon mentions, I experience the EXACT same problems.
Earlier last week, I found turning the printer off and on again will allow me an additional print. This worked for a while, then it just "up and stopped" working;
I did manage to find a way to keep the printer ON and get it to print. I would unplug the USB cable from the computer, queue the job on the printer, and then plug the USB back in, giving me one print each time. This worked the first few times, but it seems my computer has found me out and has adapted just to tease me. Now when I try that, I get the message "LJ2300: waiting for device," so I've stopped doing that, in fear of ruining something ;-).
Help? Suggestions? Others in the boat? Mark-Allan
I have the same behaviour but didn't find a solution either. But I am happy, that it doesn't seem to be a problem on my system only!

I posted my question yesterday and someone suggested trying the gimp driver for Laserjet6 but that didn't work. I tried a whole array of HP gimp drivers, but nothing worked.

I too can print once when I boot up. After that I get "Printer Busy".